summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-01-04 12:45:29 +0100
committerMathieu Othacehe <othacehe@gnu.org>2022-01-04 12:45:29 +0100
commit84207eea2c564052c05757fb0397d35088a43657 (patch)
treeb107fc5bb9bb899ff5066faf07b60f5737f7b673 /gnu/packages/patches
parente62c35f506bb6291c4e3ff67ac35e5646c9470aa (diff)
downloadguix-patches-84207eea2c564052c05757fb0397d35088a43657.tar
guix-patches-84207eea2c564052c05757fb0397d35088a43657.tar.gz
gnu: Add python-pdoc3.
* gnu/packages/patches/python-pdoc3-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/local.mk (python-pdoc3): New variable.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-pdoc3-tests.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-pdoc3-tests.patch b/gnu/packages/patches/python-pdoc3-tests.patch
new file mode 100644
index 0000000000..a411b300ee
--- /dev/null
+++ b/gnu/packages/patches/python-pdoc3-tests.patch
@@ -0,0 +1,42 @@
+Taken from upstream: https://github.com/pdoc3/pdoc/commit/4aa70de2221a34a3003a7e5f52a9b91965f0e359.patch.
+
+From 4aa70de2221a34a3003a7e5f52a9b91965f0e359 Mon Sep 17 00:00:00 2001
+From: Spencer Baugh <sbaugh@catern.com>
+Date: Thu, 23 Sep 2021 09:00:25 -0400
+Subject: [PATCH] TST: use explicit ClassWithNew instead of typing.Generic
+
+typing.Generic doesn't have a __new__ method in 3.9.
+
+Fixes https://github.com/pdoc3/pdoc/issues/355
+---
+ pdoc/test/__init__.py | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/pdoc/test/__init__.py b/pdoc/test/__init__.py
+index e8c3d94..8b67ab7 100644
+--- a/pdoc/test/__init__.py
++++ b/pdoc/test/__init__.py
+@@ -1043,16 +1043,20 @@ class C2:
+
+ self.assertEqual(pdoc.Class('C2', mod, C2).params(), ['a', 'b', 'c=None', '*', 'd=1', 'e'])
+
+- class G(typing.Generic[T]):
++ class ClassWithNew:
++ def __new__(self, arg):
++ pass
++
++ class G(ClassWithNew):
+ def __init__(self, a, b, c=100):
+ pass
+
+ self.assertEqual(pdoc.Class('G', mod, G).params(), ['a', 'b', 'c=100'])
+
+- class G2(typing.Generic[T]):
++ class G2(ClassWithNew):
+ pass
+
+- self.assertEqual(pdoc.Class('G2', mod, G2).params(), ['*args', '**kwds'])
++ self.assertEqual(pdoc.Class('G2', mod, G2).params(), ['arg'])
+
+ def test_url(self):
+ mod = pdoc.Module(EXAMPLE_MODULE)