summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-11 13:26:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 00:08:54 +0100
commit71dc990f2271dadb8aaa22b87885491466835697 (patch)
tree3f4ff2af57190258df369b759185ad6f936ec806 /gnu/packages/patches
parent461dff26518c05c22e946cc1afc89b094159a5d1 (diff)
downloadguix-patches-71dc990f2271dadb8aaa22b87885491466835697.tar
guix-patches-71dc990f2271dadb8aaa22b87885491466835697.tar.gz
gnu: python-flask-restful: Update to 0.3.9.
* gnu/packages/python-web.scm (python-flask-restful): Update to 0.3.9. [source]: Remove patch. [build-system]: Use pyproject-build-system. [arguments]: Disable "test_redirect" test; remove 'fix-imports phase. [native-inputs]: Replace python-nose with python-pytest. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/python-flask-restful-werkzeug-compat.patch: Remove file.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-flask-restful-werkzeug-compat.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/patches/python-flask-restful-werkzeug-compat.patch b/gnu/packages/patches/python-flask-restful-werkzeug-compat.patch
deleted file mode 100644
index 0e928ef455..0000000000
--- a/gnu/packages/patches/python-flask-restful-werkzeug-compat.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-We need one patch on top of 0.3.8 for compatibility with Werkzeug 1.0.
-
-Taken from upstream:
-https://github.com/flask-restful/flask-restful/commit/73376a488907af3042b52678ac4c23f8a8911e5b
-
-diff --git a/tests/test_api.py b/tests/test_api.py
-index f7f8e661..6795d362 100644
---- a/tests/test_api.py
-+++ b/tests/test_api.py
-@@ -445,7 +445,9 @@ def test_handle_non_api_error(self):
-
- resp = app.get("/foo")
- self.assertEquals(resp.status_code, 404)
-- self.assertEquals('text/html', resp.headers['Content-Type'])
-+ # in newer versions of werkzeug this is `text/html; charset=utf8`
-+ content_type, _, _ = resp.headers['Content-Type'].partition(';')
-+ self.assertEquals('text/html', content_type)
-
- def test_non_api_error_404_catchall(self):
- app = Flask(__name__)
-diff --git a/tests/test_reqparse.py b/tests/test_reqparse.py
-index 2f1fbedf..9776f17c 100644
---- a/tests/test_reqparse.py
-+++ b/tests/test_reqparse.py
-@@ -2,9 +2,9 @@
- import unittest
- from mock import Mock, patch
- from flask import Flask
--from werkzeug import exceptions, MultiDict
-+from werkzeug import exceptions
- from werkzeug.wrappers import Request
--from werkzeug.datastructures import FileStorage
-+from werkzeug.datastructures import FileStorage, MultiDict
- from flask_restful.reqparse import Argument, RequestParser, Namespace
- import six
- import decimal