summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ytfzf-updates.patch
diff options
context:
space:
mode:
authorLibreMiami <packaging-guix@libremiami.org>2021-06-26 23:12:43 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-06-28 17:43:24 -0400
commit3fdb2d679259f5d1541240dd4e9cedda17040bf2 (patch)
treedfc991c3b371772d45f3a2a00d65bcefb8884224 /gnu/packages/patches/ytfzf-updates.patch
parent1cc89f08b816f56e1bca25340e945b1cbb34f05d (diff)
downloadguix-patches-3fdb2d679259f5d1541240dd4e9cedda17040bf2.tar
guix-patches-3fdb2d679259f5d1541240dd4e9cedda17040bf2.tar.gz
gnu: Add ytfzf.
* gnu/packages/image-viewers.scm (ytfzf): New variable. Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name> Co-authored-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/patches/ytfzf-updates.patch')
-rw-r--r--gnu/packages/patches/ytfzf-updates.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/patches/ytfzf-updates.patch b/gnu/packages/patches/ytfzf-updates.patch
new file mode 100644
index 0000000000..9811bd64be
--- /dev/null
+++ b/gnu/packages/patches/ytfzf-updates.patch
@@ -0,0 +1,41 @@
+From b39ea2784c7616ca1e00bc605bf84b1360f4125f Mon Sep 17 00:00:00 2001
+From: LibreMiami <packaging-guix@libremiami.org>
+Date: Sat, 26 Jun 2021 20:34:39 -0400
+Subject: [PATCH 2/2] Disable updates within the application.
+
+---
+ ytfzf | 18 ++----------------
+ 1 file changed, 2 insertions(+), 16 deletions(-)
+
+diff --git a/ytfzf b/ytfzf
+index 28e320b..69a6f8e 100755
+--- a/ytfzf
++++ b/ytfzf
+@@ -1260,22 +1260,8 @@ EOF
+ }
+
+ update_ytfzf () {
+- branch="$1"
+- updatefile="/tmp/ytfzf-update"
+- guix-curl -L "https://raw.githubusercontent.com/pystardust/ytfzf/$branch/ytfzf" -o "$updatefile"
+-
+- if sed -n '1p' < "$updatefile" | grep -q '#!/bin/sh'; then
+- chmod 755 "$updatefile"
+- [ "$(uname)" = "Darwin" ] && prefix="/usr/local/bin" || prefix="/usr/bin"
+- function_exists "sudo" && doasroot="sudo" || doasroot="doas"
+- $doasroot cp "$updatefile" "$prefix/ytfzf"
+- unset prefix doasroot
+- else
+- printf "%bFailed to update ytfzf. Try again later.%b" "$c_red" "$c_reset"
+- fi
+-
+- rm "$updatefile"
+- exit 0
++ printf "%bUpdates have to be installed with Guix.%b\n" "$c_red" "$c_reset"
++ exit 1
+ }
+
+ #gives a value to sort by (this will give the unix time the video was uploaded)
+--
+2.32.0
+