summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/xpra-4.0.1-systemd-run.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 23:53:17 +0200
committerMarius Bakke <marius@gnu.org>2020-07-24 23:53:17 +0200
commitcbe96f14700f4805552c47d5f163a75c35f86575 (patch)
treed7791d29b283507bb8953a292d764b24774c955c /gnu/packages/patches/xpra-4.0.1-systemd-run.patch
parent337333c2567bdf767fdc8e04520c4bc0c8b33784 (diff)
parent7a9a27a051a04a7fee2e7fe40127fedbe9112cfd (diff)
downloadguix-patches-cbe96f14700f4805552c47d5f163a75c35f86575.tar
guix-patches-cbe96f14700f4805552c47d5f163a75c35f86575.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/xpra-4.0.1-systemd-run.patch')
-rw-r--r--gnu/packages/patches/xpra-4.0.1-systemd-run.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/patches/xpra-4.0.1-systemd-run.patch b/gnu/packages/patches/xpra-4.0.1-systemd-run.patch
new file mode 100644
index 0000000000..1ea11830a5
--- /dev/null
+++ b/gnu/packages/patches/xpra-4.0.1-systemd-run.patch
@@ -0,0 +1,34 @@
+Disable systemd-run if the command is not found.
+
+diff -Naur xpra-4.0.1/xpra/scripts/main.py xpra-4.0.1.patched/xpra/scripts/main.py
+--- xpra-4.0.1/xpra/scripts/main.py 2020-05-17 18:12:15.000000000 +0200
++++ xpra-4.0.1.patched/xpra/scripts/main.py 2020-06-01 12:12:18.500257507 +0200
+@@ -312,16 +312,18 @@
+ if not is_systemd_pid1():
+ return False
+ #test it:
+- cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
+- proc = Popen(cmd, stdin=None, stdout=None, stderr=None, shell=False)
+- r = pollwait(proc, timeout=1)
+- if r is None:
+- try:
+- proc.terminate()
+- except Exception:
+- pass
+- return r==0
+-
++ try:
++ cmd = ["systemd-run", "--quiet", "--user", "--scope", "--", "true"]
++ proc = Popen(cmd, stdin=None, stdout=None, stderr=None, shell=False)
++ r = pollwait(proc, timeout=1)
++ if r is None:
++ try:
++ proc.terminate()
++ except Exception:
++ pass
++ return r==0
++ except FileNotFoundError:
++ return False
+
+ def run_mode(script_file, error_cb, options, args, mode, defaults):
+ #configure default logging handler: