summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-19 16:54:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-21 17:25:54 +0200
commit8308f0ba9e65daeadcc7e8922377b3d5e9f10e05 (patch)
tree14f657223ff51e717f5152aa22de0389c33b231d /gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch
parentb1d81ba04368f17ba6d03d3e455c3d885590bb52 (diff)
downloadguix-patches-8308f0ba9e65daeadcc7e8922377b3d5e9f10e05.tar
guix-patches-8308f0ba9e65daeadcc7e8922377b3d5e9f10e05.tar.gz
gnu: webkitgtk: Update to 2.24.2 [security fixes].
This fixes CVE-2019-8595, CVE-2019-8607, and CVE-2019-8615. * gnu/packages/patches/webkitgtk-sse2.patch: Delete file. * gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/webkit.scm (webkitgtk-2.24): Update to 2.24.2. [source](patches): Add the new patch; remove 'webkitgtk-sse2.patch'.
Diffstat (limited to 'gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch')
-rw-r--r--gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch b/gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch
new file mode 100644
index 0000000000..4577c81edb
--- /dev/null
+++ b/gnu/packages/patches/webkitgtk-sans-gstreamer-gl.patch
@@ -0,0 +1,24 @@
+Fix build failure when USE_GSTREAMER_GL=off. See
+<https://bugs.webkit.org/show_bug.cgi?id=196440>.
+
+This patch is taken from the upstream source repository:
+<https://git.webkit.org/?p=WebKit.git;a=commitdiff;h=e2dd6decbe25ea9498f1ba213808f34b232740c7>.
+
+diff --git a/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp b/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp
+index 00a2af6489e..5cb5f7536ac 100644
+--- a/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp
++++ b/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp
+@@ -1000,11 +1000,13 @@ void MediaPlayerPrivateGStreamerBase::updateTextureMapperFlags()
+ break;
+ }
+
++#if USE(GSTREAMER_GL)
+ // When the imxvpudecoder is used, the texture sampling of the
+ // directviv-uploaded texture returns an RGB value, so there's no need to
+ // convert it.
+ if (m_videoDecoderPlatform != WebKitGstVideoDecoderPlatform::ImxVPU)
+ m_textureMapperFlags |= TEXTURE_MAPPER_COLOR_CONVERT_FLAG;
++#endif
+ }
+ #endif
+