summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-19 08:59:48 +0200
committerMarius Bakke <marius@gnu.org>2020-07-19 14:23:16 +0200
commitc91c132fc42c6e67140b393b963d7ced009f093e (patch)
tree1cd9a75687f00410588868d395f150ac1e668ff3 /gnu/packages/patches/ungoogled-chromium-system-nspr.patch
parentddedd2727029d0dcabf3f7a0b763f94ace5d5622 (diff)
downloadguix-patches-c91c132fc42c6e67140b393b963d7ced009f093e.tar
guix-patches-c91c132fc42c6e67140b393b963d7ced009f093e.tar.gz
gnu: ungoogled-chromium: Update to 84.0.4147.89-0.df199c0.
* gnu/packages/patches/ungoogled-chromium-system-jsoncpp.patch, gnu/packages/patches/ungoogled-chromium-system-zlib.patch: Delete files. * gnu/packages/patches/ungoogled-chromium-system-nspr.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for 84. (%ungoogled-revision): Set to df199c04ff367da59ce52a23a3f3b305dd3b00c3. (%debian-revision): Set to debian/83.0.4103.116-3. (%gentoo-revision): Set to f3f649046d31ebdbc8c4a302b2384504eff78027. (chromium-gcc-patchset, %chromium-gcc-patches): New variables. (%gentoo-patches): Remove GCC patches, which have been moved to the above repo. Add ffmpeg compatibility patch. (%debian-patches): Add zlib and jsoncpp patch; remove nspr patch. (%ungoogled-origin): Update hash. (ungoogled-chromium-snippet): Add the new GCC patches. Remove obsolete local patches, add new. (xcb-proto/python2): New variable. (ungoogled-chromium): Update to 84.0.4147.89-0..df199c0. [arguments]: Add "is_unsafe_developer_build", "max_jobs_per_link", "exclude_unwind_tables", "xcbproto_path", "perfetto_use_system_protobuf" to #:configure-flags. Remove "linux_use_bundled_binutils". Adjust vulkan header substitutions. [native-inputs]: Remove YASM. [inputs]: Change from FFMPEG-4.2 to FFMPEG. Add PROTOBUF and XCB-PROTO/PYTHON2.
Diffstat (limited to 'gnu/packages/patches/ungoogled-chromium-system-nspr.patch')
-rw-r--r--gnu/packages/patches/ungoogled-chromium-system-nspr.patch120
1 files changed, 120 insertions, 0 deletions
diff --git a/gnu/packages/patches/ungoogled-chromium-system-nspr.patch b/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
new file mode 100644
index 0000000000..6fbc0a56a7
--- /dev/null
+++ b/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
@@ -0,0 +1,120 @@
+Build with the system nspr library.
+
+Originally based on a Debian patch:
+https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/nspr.patch
+
+--- a/base/time/pr_time_unittest.cc
++++ b/base/time/pr_time_unittest.cc
+@@ -7,7 +7,7 @@
+
+ #include "base/compiler_specific.h"
+ #include "base/stl_util.h"
+-#include "base/third_party/nspr/prtime.h"
++#include <nspr/prtime.h>
+ #include "base/time/time.h"
+ #include "build/build_config.h"
+ #include "testing/gtest/include/gtest/gtest.h"
+--- a/base/time/time.cc
++++ b/base/time/time.cc
+@@ -14,7 +14,7 @@
+ #include "base/macros.h"
+ #include "base/no_destructor.h"
+ #include "base/strings/stringprintf.h"
+-#include "base/third_party/nspr/prtime.h"
++#include <nspr/prtime.h>
+ #include "base/time/time_override.h"
+ #include "build/build_config.h"
+
+--- a/base/BUILD.gn
++++ b/base/BUILD.gn
+@@ -107,6 +107,9 @@ config("base_flags") {
+ "-Wglobal-constructors",
+ ]
+ }
++ ldflags = [
++ "-lnspr4",
++ ]
+ }
+
+ config("base_implementation") {
+@@ -712,8 +715,6 @@ jumbo_component("base") {
+ "third_party/cityhash_v103/src/city_v103.h",
+ "third_party/icu/icu_utf.cc",
+ "third_party/icu/icu_utf.h",
+- "third_party/nspr/prtime.cc",
+- "third_party/nspr/prtime.h",
+ "third_party/superfasthash/superfasthash.c",
+ "thread_annotations.h",
+ "threading/hang_watcher.cc",
+--- a/tools/gn/build/gen.py
++++ b/tools/gn/build/gen.py
+@@ -339,6 +339,9 @@ def WriteGNNinja(path, platform, host, o
+ if not options.no_static_libstdcpp:
+ ldflags.append('-static-libstdc++')
+
++ # Additional system libraries that are used.
++ libs.append('-lnspr4')
++
+ # This is needed by libc++.
+ if not platform.is_mingw():
+ libs.append('-ldl')
+--- a/third_party/blink/renderer/platform/BUILD.gn
++++ b/third_party/blink/renderer/platform/BUILD.gn
+@@ -103,6 +103,9 @@
+ "//build/win:default_exe_manifest",
+ "//third_party/icu",
+ ]
++ ldflags = [
++ "-lnspr4"
++ ]
+ }
+
+ # This isn't strictly necessary since we can just add the deps to "platform",
+--- a/third_party/crashpad/crashpad/handler/BUILD.gn
++++ b/third_party/crashpad/crashpad/handler/BUILD.gn
+@@ -140,6 +140,9 @@
+ "../third_party/mini_chromium:base",
+ "../tools:tool_support",
+ ]
++ ldflags = [
++ "-lnspr4"
++ ]
+
+ if (crashpad_is_win) {
+ if (crashpad_is_in_chromium || crashpad_is_in_dart) {
+--- a/chrome/common/search/BUILD.gn
++++ b/chrome/common/search/BUILD.gn
+@@ -20,6 +20,9 @@
+ "//chrome/common/themes:autogenerated_theme_util",
+ "//skia",
+ ]
++ ldflags = [
++ "-lnspr4"
++ ]
+ }
+
+ compiled_action("generate_chrome_colors_info") {
+--- a/components/url_formatter/spoof_checks/top_domains/BUILD.gn
++++ b/components/url_formatter/spoof_checks/top_domains/BUILD.gn
+@@ -31,6 +31,9 @@
+ "//net/tools/huffman_trie:huffman_trie_generator_sources",
+ "//url:url",
+ ]
++ ldflags = [
++ "-lnspr4",
++ ]
+ if (is_ios) {
+ libs = [ "UIKit.framework" ]
+ }
+--- a/components/schema_org/BUILD.gn
++++ b/components/schema_org/BUILD.gn
+@@ -33,6 +33,9 @@
+ "//base",
+ "//url",
+ ]
++ ldflags = [
++ "-lnspr4",
++ ]
+ }
+
+ compiled_action("schema_org_name_data") {