summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/thefuck-test-environ.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-30 22:59:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:59:53 +0200
commit84157bb8bf2c610584e0836047da4c710f8eaf76 (patch)
treebe5d8c7238e32802221db55a3ee83e7f6a58affb /gnu/packages/patches/thefuck-test-environ.patch
parentfa63939acba69e11df44073a7eb687bd2ba48349 (diff)
parent03d0aa8b22223b67ec9bbd363c4d5800efdbaf82 (diff)
downloadguix-patches-84157bb8bf2c610584e0836047da4c710f8eaf76.tar
guix-patches-84157bb8bf2c610584e0836047da4c710f8eaf76.tar.gz
Merge branch 'master' into core-updates
Most conflicts are from 6fd52309b8f52c9bb59fccffac53e029ce94b698.
Diffstat (limited to 'gnu/packages/patches/thefuck-test-environ.patch')
-rw-r--r--gnu/packages/patches/thefuck-test-environ.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/thefuck-test-environ.patch b/gnu/packages/patches/thefuck-test-environ.patch
new file mode 100644
index 0000000000..0c602a38c4
--- /dev/null
+++ b/gnu/packages/patches/thefuck-test-environ.patch
@@ -0,0 +1,14 @@
+Retain environment setting of "HOME" for tests that need os.path.expanduser()
+to return a readable directory in the build chroot.
+
+--- thefuck-3.15/tests/test_conf.py
++++ thefuck-3.15/tests/test_conf.py
+@@ -12,7 +12,7 @@
+
+ @pytest.fixture
+ def environ(monkeypatch):
+- data = {}
++ data = {"HOME": os.environ.get("HOME")}
+ monkeypatch.setattr('thefuck.conf.os.environ', data)
+ return data
+