summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/spice-fix-test-armhf.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 00:09:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-15 00:09:46 +0100
commit3cfe76bec06fbd8bb7e7cb3387866fefbcad674f (patch)
treeb66780d205fb50fd44d0bbb38f5df99cf3167ba1 /gnu/packages/patches/spice-fix-test-armhf.patch
parentec836b46bf52a5f86c61f50e3a2c3330a7ee3665 (diff)
parent574a71a7a9668aa184661c58e1f18a4d4fccd792 (diff)
downloadguix-patches-3cfe76bec06fbd8bb7e7cb3387866fefbcad674f.tar
guix-patches-3cfe76bec06fbd8bb7e7cb3387866fefbcad674f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/spice-fix-test-armhf.patch')
-rw-r--r--gnu/packages/patches/spice-fix-test-armhf.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/spice-fix-test-armhf.patch b/gnu/packages/patches/spice-fix-test-armhf.patch
new file mode 100644
index 0000000000..5c51bd6ede
--- /dev/null
+++ b/gnu/packages/patches/spice-fix-test-armhf.patch
@@ -0,0 +1,19 @@
+Fix test failure on armhf and ppc64el:
+https://gitlab.freedesktop.org/spice/spice-server/issues/31
+
+Taken from upstream:
+https://gitlab.freedesktop.org/spice/spice/commit/19f9f454e0777d851f26d14df0c7984267c57015
+
+diff --git a/server/tests/test-qxl-parsing.c b/server/tests/test-qxl-parsing.c
+index 60ca8f88c62441e02577ced21e4f60a08ad4171a..234bdabc9ce619d0799b5136f1d72357b0b2f490 100644
+--- a/server/tests/test-qxl-parsing.c
++++ b/server/tests/test-qxl-parsing.c
+@@ -96,7 +96,7 @@ static void test_memslot_invalid_slot_id(void)
+ RedMemSlotInfo mem_info;
+ init_meminfo(&mem_info);
+
+- memslot_get_virt(&mem_info, 1 << mem_info.memslot_id_shift, 16, 0);
++ memslot_get_virt(&mem_info, UINT64_C(1) << mem_info.memslot_id_shift, 16, 0);
+ }
+
+ static void test_memslot_invalid_addresses(void)