summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sphinxbase-fix-doxygen.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-05 21:56:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-05 22:30:04 +0300
commitde3c03a47160dec355d9b19ad5ca210d90c15fd7 (patch)
tree4ca6dc05b5fc9530d812bbb269f1c61ab9efccf3 /gnu/packages/patches/sphinxbase-fix-doxygen.patch
parentab6fe9d362046231ad6f46eccfd1ea2c9c80b401 (diff)
parentb8477cab7bccc4191ed3dfa3f149aec7917834d8 (diff)
downloadguix-patches-de3c03a47160dec355d9b19ad5ca210d90c15fd7.tar
guix-patches-de3c03a47160dec355d9b19ad5ca210d90c15fd7.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/patches/sphinxbase-fix-doxygen.patch')
-rw-r--r--gnu/packages/patches/sphinxbase-fix-doxygen.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/sphinxbase-fix-doxygen.patch b/gnu/packages/patches/sphinxbase-fix-doxygen.patch
new file mode 100644
index 0000000000..c8ebc52628
--- /dev/null
+++ b/gnu/packages/patches/sphinxbase-fix-doxygen.patch
@@ -0,0 +1,24 @@
+https://github.com/cmusphinx/sphinxbase/commit/6989c52a3fb9473fd61326e548440fff887525c2
+
+commit 6989c52a3fb9473fd61326e548440fff887525c2
+Author: Michel Zou <xantares09@hotmail.com>
+Date: Thu Feb 6 07:02:06 2020 +0100
+
+ Fix doxy2swig.py IndexError: list index out of range
+
+diff --git a/doc/doxy2swig.py b/doc/doxy2swig.py
+index 5589b0d..a01c4b1 100644
+--- a/doc/doxy2swig.py
++++ b/doc/doxy2swig.py
+@@ -299,7 +299,10 @@ class Doxy2SWIG:
+ name = first['name'].firstChild.data
+
+ for n in node.getElementsByTagName('param'):
+- arg_type = n.getElementsByTagName('type')[0]
++ elts = n.getElementsByTagName('type')
++ if len(elts) == 0:
++ continue
++ arg_type = elts[0]
+ ref = self.get_specific_nodes(arg_type, ('ref'))
+ if 'ref' in ref:
+ type_name = ref['ref'].firstChild.data