summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /gnu/packages/patches/sbcl-geco-fix-organism-class.patch
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/patches/sbcl-geco-fix-organism-class.patch')
-rw-r--r--gnu/packages/patches/sbcl-geco-fix-organism-class.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-geco-fix-organism-class.patch b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
new file mode 100644
index 0000000000..817596241e
--- /dev/null
+++ b/gnu/packages/patches/sbcl-geco-fix-organism-class.patch
@@ -0,0 +1,13 @@
+Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
+
+--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
++++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
+@@ -148,7 +148,7 @@
+ :accessor score
+ :initarg :score
+ :initform 'nil
+- :type number)
++ :type (or number null))
+ (NORMALIZED-SCORE
+ :accessor normalized-score
+ :initarg :normalized-score