summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rxvt-unicode-escape-sequences.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:21:57 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:21:57 +0200
commit4ea6852c5ff1606cf6848f3ddbb669120b228c13 (patch)
tree6f21e3cad7a3cad4eb847f404b6ba6450dfc2bef /gnu/packages/patches/rxvt-unicode-escape-sequences.patch
parentfcf45f8d756b92c5a99308d671af8992b489c4b4 (diff)
parentd4ffa9630277fa8699c783c08381d688626d4bc3 (diff)
downloadguix-patches-4ea6852c5ff1606cf6848f3ddbb669120b228c13.tar
guix-patches-4ea6852c5ff1606cf6848f3ddbb669120b228c13.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/rxvt-unicode-escape-sequences.patch')
-rw-r--r--gnu/packages/patches/rxvt-unicode-escape-sequences.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/patches/rxvt-unicode-escape-sequences.patch b/gnu/packages/patches/rxvt-unicode-escape-sequences.patch
deleted file mode 100644
index 064dd51e2d..0000000000
--- a/gnu/packages/patches/rxvt-unicode-escape-sequences.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-This patch prevents a code execution vector involving terminal escape
-sequences when rxvt-unicode is in "secure mode".
-
-This change was spurred by the following conversation on the
-oss-security mailing list:
-
-Problem description and proof of concept:
-http://seclists.org/oss-sec/2017/q2/190
-
-Upstream response:
-http://seclists.org/oss-sec/2017/q2/291
-
-Patch copied from upstream source repository:
-http://cvs.schmorp.de/rxvt-unicode/src/command.C?r1=1.582&r2=1.583
-
---- rxvt-unicode/src/command.C 2016/07/14 05:33:26 1.582
-+++ rxvt-unicode/src/command.C 2017/05/18 02:43:18 1.583
-@@ -2695,7 +2695,7 @@
- /* kidnapped escape sequence: Should be 8.3.48 */
- case C1_ESA: /* ESC G */
- // used by original rxvt for rob nations own graphics mode
-- if (cmd_getc () == 'Q')
-+ if (cmd_getc () == 'Q' && option (Opt_insecure))
- tt_printf ("\033G0\012"); /* query graphics - no graphics */
- break;
-
-@@ -2914,7 +2914,7 @@
- break;
-
- case CSI_CUB: /* 8.3.18: (1) CURSOR LEFT */
-- case CSI_HPB: /* 8.3.59: (1) CHARACTER POSITION BACKWARD */
-+ case CSI_HPB: /* 8.3.59: (1) CHARACTER POSITION BACKWARD */
- #ifdef ISO6429
- arg[0] = -arg[0];
- #else /* emulate common DEC VTs */