summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-08-10 23:51:06 +0200
committerLudovic Courtès <ludo@gnu.org>2021-08-11 16:35:28 +0200
commit168d107abf5608e6a1bfb37ee3448c4087856602 (patch)
tree55e21b85e42c9c0e77a42b9207e21c01d63bb856 /gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch
parent9b54559e237b40ea56a604fa50b4dfa8a4437bc5 (diff)
downloadguix-patches-168d107abf5608e6a1bfb37ee3448c4087856602.tar
guix-patches-168d107abf5608e6a1bfb37ee3448c4087856602.tar.gz
gnu: rocm-opencl-runtime: Shorten patch file name.
This appeases 'guix lint -c patch-file-names'. * gnu/packages/patches/rocm-opencl-runtime-3.10.0-add-rocclr-include-directories.patch: Rename to... * gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch: ... this. * gnu/packages/rocm.scm (rocm-opencl-runtime)[source]: Adjust accordingly. * gnu/local.mk (dist_patch_DATA): Likewise.
Diffstat (limited to 'gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch')
-rw-r--r--gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch b/gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch
new file mode 100644
index 0000000000..d81bb0747f
--- /dev/null
+++ b/gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch
@@ -0,0 +1,14 @@
+Add missing include dirs for ROCclr.
+
+--- a/amdocl/CMakeLists.txt 2020-12-05 22:05:55.838529158 +0100
++++ b/amdocl/CMakeLists.txt 2020-12-05 22:07:35.677524507 +0100
+@@ -23,6 +23,9 @@
+ include_directories(${CMAKE_CURRENT_LIST_DIR}/../khronos)
+ include_directories(${CMAKE_CURRENT_LIST_DIR}/../khronos/headers)
+ include_directories(${CMAKE_CURRENT_LIST_DIR}/../khronos/headers/opencl2.2)
++include_directories(${ROCclr_DIR}/../../../include)
++include_directories(${ROCclr_DIR}/../../../include/compiler/lib/include/)
++include_directories(${ROCclr_DIR}/../../../include/elf/)
+
+ if((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") OR
+ (CMAKE_${COMPILER}_COMPILER_ID MATCHES "Clang"))