summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qemu-multiple-smb-shares.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-16 02:09:10 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-16 02:09:10 +0100
commit161ed5476d27a69bbb940fd4a76f67976bd1d91e (patch)
tree213a73c471ba067f91a7e33aa3178d5fe2832515 /gnu/packages/patches/qemu-multiple-smb-shares.patch
parentd510ab46144b4c7cb27e383f0031c9b363335cd3 (diff)
downloadguix-patches-161ed5476d27a69bbb940fd4a76f67976bd1d91e.tar
guix-patches-161ed5476d27a69bbb940fd4a76f67976bd1d91e.tar.gz
gnu: qemu-kvm: Add patch to have multiple SMB shares.
* gnu/packages/qemu.scm (qemu-kvm/smb-shares): New variable. * gnu/packages/patches/qemu-multiple-smb-shares.patch: New file. * Makefile.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/qemu-multiple-smb-shares.patch')
-rw-r--r--gnu/packages/patches/qemu-multiple-smb-shares.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/qemu-multiple-smb-shares.patch b/gnu/packages/patches/qemu-multiple-smb-shares.patch
new file mode 100644
index 0000000000..c20066cbfe
--- /dev/null
+++ b/gnu/packages/patches/qemu-multiple-smb-shares.patch
@@ -0,0 +1,20 @@
+This file extends `-smb' to add a share for the Nix store, and changes
+the name of the default share.
+
+--- a/net/slirp.c
++++ b/net/slirp.c
+@@ -515,8 +515,12 @@ static int slirp_smb(SlirpState* s, const char *exported_dir,
+ "log file=%s/log.smbd\n"
+ "smb passwd file=%s/smbpasswd\n"
+ "security = share\n"
+- "[qemu]\n"
+- "path=%s\n"
++ "[store]\n"
++ "path=/nix/store\n"
++ "read only=yes\n"
++ "guest ok=yes\n"
++ "[xchg]\n"
++ "path=%s/xchg\n"
+ "read only=no\n"
+ "guest ok=yes\n",
+ s->smb_dir,