summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-22 01:47:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-22 17:02:47 +0100
commit7ff3f3d22caaf03948a60ae691313db28f4fab06 (patch)
tree5428e6edf032a454c37b8aad1cb6e684c4b80b3c /gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch
parentec8130eb23b79c2b8b61043f25dafcefd0daafe7 (diff)
downloadguix-patches-7ff3f3d22caaf03948a60ae691313db28f4fab06.tar
guix-patches-7ff3f3d22caaf03948a60ae691313db28f4fab06.tar.gz
gnu: python-scikit-learn: Update to 0.20.1.
* gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/machine-learning.scm (python-scikit-learn): Update to 0.20.1. [source](patches): Remove. [arguments]: Skip network tests with pytest instead of deleting files. Make sure $HOME is writable. (python2-scikit-learn): Rewrite in terms of PACKAGE-WITH-PYTHON2.
Diffstat (limited to 'gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch')
-rw-r--r--gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch b/gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch
deleted file mode 100644
index 90328cc0eb..0000000000
--- a/gnu/packages/patches/python-scikit-learn-fix-test-non-determinism.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-This patch stops a test sometimes failing because of non-determinism. See
-https://github.com/scikit-learn/scikit-learn/pull/9542
-
-From ff9f6db6e8b59c2b3528c8137ed4054f57c1d7c4 Mon Sep 17 00:00:00 2001
-From: Hanmin Qin <qinhanmin2005@sina.com>
-Date: Sun, 13 Aug 2017 22:13:49 +0800
-Subject: [PATCH] add random_state
-
----
- sklearn/tests/test_kernel_ridge.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/sklearn/tests/test_kernel_ridge.py b/sklearn/tests/test_kernel_ridge.py
-index 4750a096ac6..979875870b6 100644
---- a/sklearn/tests/test_kernel_ridge.py
-+++ b/sklearn/tests/test_kernel_ridge.py
-@@ -10,7 +10,7 @@
- from sklearn.utils.testing import assert_array_almost_equal
-
-
--X, y = make_regression(n_features=10)
-+X, y = make_regression(n_features=10, random_state=0)
- Xcsr = sp.csr_matrix(X)
- Xcsc = sp.csc_matrix(X)
- Y = np.array([y, y]).T