summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-paste-remove-timing-test.patch
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-25 11:01:45 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-25 11:01:45 -0800
commitc4a7904c21c854d5f1d49eeecf76bbefe087a893 (patch)
tree4ca352c1d045d4dca350e34871b5bf2c0c7210a6 /gnu/packages/patches/python-paste-remove-timing-test.patch
parente62b5c690317ec6c5e35ce267b5c683bbd320342 (diff)
downloadguix-patches-c4a7904c21c854d5f1d49eeecf76bbefe087a893.tar
guix-patches-c4a7904c21c854d5f1d49eeecf76bbefe087a893.tar.gz
gnu: Add python-paste.
* gnu/packages/python.scm (python-paste, python2-paste): New variables. * gnu/packages/patches/python-paste-remove-timing-test.patch: New file. * gnu/packages/patches/python-paste-remove-website-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/python-paste-remove-timing-test.patch')
-rw-r--r--gnu/packages/patches/python-paste-remove-timing-test.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-paste-remove-timing-test.patch b/gnu/packages/patches/python-paste-remove-timing-test.patch
new file mode 100644
index 0000000000..6ab8d1a59c
--- /dev/null
+++ b/gnu/packages/patches/python-paste-remove-timing-test.patch
@@ -0,0 +1,16 @@
+Remove this test to verify that things were modified since a certain time.
+
+That assumption doesn't hold up when your environment doesn't have access to a
+real clock and thinks it's living in 1970 :)
+
+--- a/tests/test_fileapp.py 2015-04-23 13:48:37.000000000 -0700
++++ b/tests/test_fileapp.py 2016-02-22 19:20:08.332802417 -0800
+@@ -223,8 +223,6 @@
+ status=304)
+ res = app.get('/', headers={'If-None-Match': 'asdf'},
+ status=200)
+- res = app.get('/', headers={'If-Modified-Since': 'Sat, 1 Jan 2005 12:00:00 GMT'},
+- status=200)
+ res = app.get('/', headers={'If-Modified-Since': last_mod + '; length=100'},
+ status=304)
+ res = app.get('/', headers={'If-Modified-Since': 'invalid date'},