summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-jedi-sort-project-test.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-05 21:56:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-05 22:30:04 +0300
commitde3c03a47160dec355d9b19ad5ca210d90c15fd7 (patch)
tree4ca6dc05b5fc9530d812bbb269f1c61ab9efccf3 /gnu/packages/patches/python-jedi-sort-project-test.patch
parentab6fe9d362046231ad6f46eccfd1ea2c9c80b401 (diff)
parentb8477cab7bccc4191ed3dfa3f149aec7917834d8 (diff)
downloadguix-patches-de3c03a47160dec355d9b19ad5ca210d90c15fd7.tar
guix-patches-de3c03a47160dec355d9b19ad5ca210d90c15fd7.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/patches/python-jedi-sort-project-test.patch')
-rw-r--r--gnu/packages/patches/python-jedi-sort-project-test.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/python-jedi-sort-project-test.patch b/gnu/packages/patches/python-jedi-sort-project-test.patch
deleted file mode 100644
index b2d602dfe6..0000000000
--- a/gnu/packages/patches/python-jedi-sort-project-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Sort the result of file system traversal to avoid test failure on different
-file systems.
-
-Taken from upstream:
-https://github.com/davidhalter/jedi/commit/7ff76bb7d0d94514e17cd1647f4ffaf533dd55f5
-
-diff --git a/test/test_api/test_project.py b/test/test_api/test_project.py
---- a/test/test_api/test_project.py
-+++ b/test/test_api/test_project.py
-@@ -135,7 +135,7 @@ def test_search(string, full_names, kwargs, skip_pre_python36):
- defs = project.complete_search(string, **kwargs)
- else:
- defs = project.search(string, **kwargs)
-- assert [('stub:' if d.is_stub() else '') + d.full_name for d in defs] == full_names
-+ assert sorted([('stub:' if d.is_stub() else '') + d.full_name for d in defs]) == full_names
-
-
- @pytest.mark.parametrize(