summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-cairocffi-dlopen-path.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-25 21:30:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-25 21:30:18 +0300
commit95da60845127731f1395f8a7f5ab7e235aca5dfc (patch)
tree0d2fec7b243b91ac7a5d6140d4edad52946174e6 /gnu/packages/patches/python-cairocffi-dlopen-path.patch
parent2a43df2270345babd768b0057d3cccdf08398e77 (diff)
parentb19f3337eae86ad0cd910da45b9d45e3866c98fd (diff)
downloadguix-patches-95da60845127731f1395f8a7f5ab7e235aca5dfc.tar
guix-patches-95da60845127731f1395f8a7f5ab7e235aca5dfc.tar.gz
Merge remote-tracking branch 'origin/master' into qt-updates
Diffstat (limited to 'gnu/packages/patches/python-cairocffi-dlopen-path.patch')
-rw-r--r--gnu/packages/patches/python-cairocffi-dlopen-path.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-cairocffi-dlopen-path.patch b/gnu/packages/patches/python-cairocffi-dlopen-path.patch
new file mode 100644
index 0000000000..e7a7fe3737
--- /dev/null
+++ b/gnu/packages/patches/python-cairocffi-dlopen-path.patch
@@ -0,0 +1,10 @@
+--- cairocffi-0.8.0/cairocffi/__init__.py.orig 2018-07-16 11:00:59.075664158 +0200
++++ cairocffi-0.8.0/cairocffi/__init__.py 2018-07-16 17:09:42.471958015 +0200
+@@ -35,6 +35,7 @@
+ return lib
+ except OSError:
+ pass
++ return ffi.dlopen(name)
+ raise OSError("dlopen() failed to load a library: %s" % ' / '.join(names))
+
+