summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-3.8-fix-tests.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-12 22:26:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-12 23:55:48 -0500
commitb5c4f5d9eec34b8ec83cf8ffec085a2cd67e7c5d (patch)
tree2e7e4f6dfac7f0a48c9def1b8475c9a6d98fe9e0 /gnu/packages/patches/python-3.8-fix-tests.patch
parentf1eea19c9ae27e5d275b083bbf280e5b59e5e57a (diff)
downloadguix-patches-b5c4f5d9eec34b8ec83cf8ffec085a2cd67e7c5d.tar
guix-patches-b5c4f5d9eec34b8ec83cf8ffec085a2cd67e7c5d.tar.gz
gnu: python: Update to 3.9.1 and streamline package definition.
* gnu/packages/python.scm (python-3.8): Rename to... (python-3.9): ... this. Update version to 3.9.1. [arguments]{make-flags}: Restore test_socket test. [phases]{unset-SOURCE_DATE_EPOCH, reset-SOURCE_DATE_EPOCH}: Remove phases. {rebuild-bytecode}: Simplify code. Set the invalidation-mode argument of the compileall module to "unchecked-hash", to ensure determinism. (python-3): Adjust to refer to python-3.9. * gnu/packages/patches/python-3-fix-tests.patch: Rebase and extend patch. * gnu/packages/patches/python-3.8-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/patches/python-3.8-fix-tests.patch')
-rw-r--r--gnu/packages/patches/python-3.8-fix-tests.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/gnu/packages/patches/python-3.8-fix-tests.patch b/gnu/packages/patches/python-3.8-fix-tests.patch
deleted file mode 100644
index 4fbdd444c7..0000000000
--- a/gnu/packages/patches/python-3.8-fix-tests.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/Lib/test/_test_multiprocessing.py b/Lib/test/_test_multiprocessing.py
-index 1474624..887f8ee 100644
---- a/Lib/test/_test_multiprocessing.py
-+++ b/Lib/test/_test_multiprocessing.py
-@@ -3801,6 +3801,7 @@ class _TestSharedMemory(BaseTestCase):
- sms.close()
-
- @unittest.skipIf(os.name != "posix", "not feasible in non-posix platforms")
-+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
- def test_shared_memory_SharedMemoryServer_ignores_sigint(self):
- # bpo-36368: protect SharedMemoryManager server process from
- # KeyboardInterrupt signals.
-diff --git a/Lib/test/test_signal.py b/Lib/test/test_signal.py
-index d41e94b..a1c15e7 100644
---- a/Lib/test/test_signal.py
-+++ b/Lib/test/test_signal.py
-@@ -78,6 +78,7 @@ class PosixTests(unittest.TestCase):
- self.assertLess(len(s), signal.NSIG)
-
- @unittest.skipUnless(sys.executable, "sys.executable required.")
-+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
- def test_keyboard_interrupt_exit_code(self):
- """KeyboardInterrupt triggers exit via SIGINT."""
- process = subprocess.run(
-@@ -128,6 +129,7 @@ class WindowsSignalTests(unittest.TestCase):
- signal.signal(7, handler)
-
- @unittest.skipUnless(sys.executable, "sys.executable required.")
-+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
- def test_keyboard_interrupt_exit_code(self):
- """KeyboardInterrupt triggers an exit using STATUS_CONTROL_C_EXIT."""
- # We don't test via os.kill(os.getpid(), signal.CTRL_C_EVENT) here
-@@ -1245,6 +1247,7 @@ class StressTest(unittest.TestCase):
-
- class RaiseSignalTest(unittest.TestCase):
-
-+ @unittest.skipUnless(sys.stdin.isatty(), "KeyboardInterrupts require a TTY device")
- def test_sigint(self):
- with self.assertRaises(KeyboardInterrupt):
- signal.raise_signal(signal.SIGINT)
---
-2.23.0