summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-2.7-search-paths.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-08 00:05:34 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-08 00:05:34 +0200
commit6a20289d5a38520fd79e80c256a0315c96a46347 (patch)
tree453242901e55b21078e621aaccfe325109982b79 /gnu/packages/patches/python-2.7-search-paths.patch
parentafa181fff435b4e549092c2639e8165069082755 (diff)
downloadguix-patches-6a20289d5a38520fd79e80c256a0315c96a46347.tar
guix-patches-6a20289d5a38520fd79e80c256a0315c96a46347.tar.gz
gnu: python: Simplify list of configure flags.
* gnu/packages/patches/python-2.7-search-paths.patch, gnu/packages/patches/python-3-search-paths.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/python.scm (python-2)[source]: Use first patch. [arguments]: Remove now unneeded CPPFLAGS and LDFLAGS. (python)[source]: Use second patch. (python-minimal)[arguments]: Remove CPPFLAGS and LDFLAGS.
Diffstat (limited to 'gnu/packages/patches/python-2.7-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-2.7-search-paths.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-2.7-search-paths.patch b/gnu/packages/patches/python-2.7-search-paths.patch
new file mode 100644
index 0000000000..6e5339f3a6
--- /dev/null
+++ b/gnu/packages/patches/python-2.7-search-paths.patch
@@ -0,0 +1,16 @@
+Make sure the build system honors CPATH and LIBRARY_PATH when looking for
+headers and libraries.
+
+--- Python-2.7.10/setup.py 2015-10-07 18:33:18.125153186 +0200
++++ Python-2.7.10/setup.py 2015-10-07 18:33:47.497347552 +0200
+@@ -526,6 +526,10 @@ class PyBuildExt(build_ext):
+ inc_dirs += ['/system/include', '/atheos/autolnk/include']
+ inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
+
++ # Always honor these variables.
++ lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
++ inc_dirs += os.getenv('CPATH', '').split(os.pathsep)
++
+ # OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
+ if host_platform in ['osf1', 'unixware7', 'openunix8']:
+ lib_dirs += ['/usr/ccs/lib']