summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pulseaudio-test-timeouts.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-10-31 23:05:27 -0400
committerLudovic Courtès <ludo@gnu.org>2013-11-01 12:48:25 +0100
commitb645425f71a5a777e7658bbdac0e22e134d44db5 (patch)
tree5519f0910e16296260526ce4061407462728c63f /gnu/packages/patches/pulseaudio-test-timeouts.patch
parentcdbca518ca797cae61c7829e51649b55c47f6a2f (diff)
downloadguix-patches-b645425f71a5a777e7658bbdac0e22e134d44db5.tar
guix-patches-b645425f71a5a777e7658bbdac0e22e134d44db5.tar.gz
gnu: pulseaudio: increase timeout of thread test.
* gnu/packages/patches/pulseaudio-test-timeouts.patch: New file. * gnu/packages/pulseaudio.scm (pulseaudio): Add patch. * gnu-system.am (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/patches/pulseaudio-test-timeouts.patch')
-rw-r--r--gnu/packages/patches/pulseaudio-test-timeouts.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/pulseaudio-test-timeouts.patch b/gnu/packages/patches/pulseaudio-test-timeouts.patch
new file mode 100644
index 0000000000..ab818ad0aa
--- /dev/null
+++ b/gnu/packages/patches/pulseaudio-test-timeouts.patch
@@ -0,0 +1,19 @@
+Increase the timeout of the thread test. Hydra was intermittedly
+failing this test due to premature timeout, and slower machines
+consistently fail.
+
+Patch by Mark H Weaver <mhw@netris.org>.
+
+--- pulseaudio/src/tests/thread-test.c.orig 2012-09-26 07:27:01.000000000 -0400
++++ pulseaudio/src/tests/thread-test.c 2013-10-31 22:53:23.224000184 -0400
+@@ -152,6 +152,10 @@
+ s = suite_create("Thread");
+ tc = tcase_create("thread");
+ tcase_add_test(tc, thread_test);
++ /* the default timeout is too small,
++ * set it to a reasonable large one.
++ */
++ tcase_set_timeout(tc, 60 * 60);
+ suite_add_tcase(s, tc);
+
+ sr = srunner_create(s);