summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/psm-arch.patch
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-11-07 17:57:47 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-07 18:09:13 +0100
commitfd23d259cd0c13cd670aea7190a00a531da4c90d (patch)
treef4da0255275d125d00b1fab7ab9d12e4aa82a09a /gnu/packages/patches/psm-arch.patch
parent63b7fbe1bb3ff2b8a97793f91a0a6d7de8977a75 (diff)
downloadguix-patches-fd23d259cd0c13cd670aea7190a00a531da4c90d.tar
guix-patches-fd23d259cd0c13cd670aea7190a00a531da4c90d.tar.gz
gnu: Add PSM.
* gnu/packages/linux.scm (psm): New variable. * gnu/packages/patches/psm-arch.patch, gnu/packages/patches/psm-ldflags.patch, gnu/packages/patches/psm-repro.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/psm-arch.patch')
-rw-r--r--gnu/packages/patches/psm-arch.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/psm-arch.patch b/gnu/packages/patches/psm-arch.patch
new file mode 100644
index 0000000000..3d95c28595
--- /dev/null
+++ b/gnu/packages/patches/psm-arch.patch
@@ -0,0 +1,13 @@
+Use 'uname -m', which in practice returns the processor architecture.
+
+--- psm-3.3/buildflags.mak~ 2014-08-20 21:00:18.000000000 +0100
++++ psm-3.3/buildflags.mak 2017-10-22 12:02:12.855291447 +0100
+@@ -38,7 +38,7 @@
+ endif
+
+ export os ?= $(shell uname -s | tr '[A-Z]' '[a-z]')
+-export arch := $(shell uname -p | sed -e 's,\(i[456]86\|athlon$$\),i386,')
++export arch := $(shell uname -m | sed -e 's,\(i[456]86\|athlon$$\),i386,')
+
+ CC ?= gcc
+