summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pango-skip-libthai-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:55:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-11 18:59:23 +0100
commit869b63cb93c68a2825bfe25b652d5481555f9b12 (patch)
tree7d26d3969a7042d04079780304b07b81c55581db /gnu/packages/patches/pango-skip-libthai-test.patch
parent8419a7ed44ee86e1b93b9dd1779c9ab192f98175 (diff)
downloadguix-patches-869b63cb93c68a2825bfe25b652d5481555f9b12.tar
guix-patches-869b63cb93c68a2825bfe25b652d5481555f9b12.tar.gz
gnu: pango: Update to 1.44.7.
* gnu/packages/patches/pango-skip-libthai-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gtk.scm (pango): Update to 1.44.7. [source](patches): New field. [build-system]: Switch to MESON-BUILD-SYSTEM. [arguments]: Disable tests that require the Cantarell font. [inputs]: Move LIBXFT ... [propagated-inputs]: ... here. (pango-1.42): New public variable. * gnu/packages/gnome.scm (librsvg)[inputs]: Change from PANGO to PANGO-1.42.
Diffstat (limited to 'gnu/packages/patches/pango-skip-libthai-test.patch')
-rw-r--r--gnu/packages/patches/pango-skip-libthai-test.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/pango-skip-libthai-test.patch b/gnu/packages/patches/pango-skip-libthai-test.patch
new file mode 100644
index 0000000000..98732b5391
--- /dev/null
+++ b/gnu/packages/patches/pango-skip-libthai-test.patch
@@ -0,0 +1,23 @@
+Skip Thai character test when libthai is unavailable.
+
+Taken from upstream bug tracker:
+https://gitlab.gnome.org/GNOME/pango/merge_requests/161
+https://gitlab.gnome.org/GNOME/pango/commit/b73284747ac937e31dc9191f84ed6e24284c88ee
+
+diff --git a/tests/test-break.c b/tests/test-break.c
+index 8549b678bba69360d07dce3af21d915412f20d51..47fa3009165e19a331aa04a0df4351ae2323933b 100644
+--- a/tests/test-break.c
++++ b/tests/test-break.c
+@@ -305,6 +305,12 @@ main (int argc, char *argv[])
+ if (!strstr (name, "break"))
+ continue;
+
++#ifndef HAVE_LIBTHAI
++ /* four.break involves Thai, so only test it when we have libthai */
++ if (strstr (name, "four.break"))
++ continue;
++#endif
++
+ path = g_strdup_printf ("/break/%s", name);
+ g_test_add_data_func_full (path, g_test_build_filename (G_TEST_DIST, "breaks", name, NULL),
+ test_break, g_free);