summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openimageio-boost-1.60.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-20 11:42:02 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-20 11:42:17 +0200
commit7575655212ecfbcd1f04e429c8a7a41f8720d027 (patch)
tree558982d3cf50ef6b19ef293850de1f485fde66a6 /gnu/packages/patches/openimageio-boost-1.60.patch
parent5d4c90ae02f1e0b42d575bba2d828d63aaf79be5 (diff)
parent5f01078129f4eaa4760a14f22761cf357afb6738 (diff)
downloadguix-patches-7575655212ecfbcd1f04e429c8a7a41f8720d027.tar
guix-patches-7575655212ecfbcd1f04e429c8a7a41f8720d027.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/openimageio-boost-1.60.patch')
-rw-r--r--gnu/packages/patches/openimageio-boost-1.60.patch47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/patches/openimageio-boost-1.60.patch b/gnu/packages/patches/openimageio-boost-1.60.patch
deleted file mode 100644
index 92fc3237bb..0000000000
--- a/gnu/packages/patches/openimageio-boost-1.60.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 875fbbd92695397bfc83d1cd5fdd4094e1d50199 Mon Sep 17 00:00:00 2001
-From: Larry Gritz <lg@larrygritz.com>
-Date: Mon, 28 Dec 2015 11:46:07 -0800
-Subject: [PATCH] Python ImageCache binding fixes -- disable broken calls
-
-Some of these calls (thankfully undocumented and presumably unused)
-are horribly broken. They compiled before, but with new Boost 1.60
-they don't even compile properly. So just comment them out on this
-obsolete branch. They are fully fixed in RB-1.6 and beyond.
-
---- a/src/python/py_imagecache.cpp
-+++ b/src/python/py_imagecache.cpp
-@@ -199,23 +199,24 @@ void declare_imagecache()
- .def("destroy", &ImageCacheWrap::destroy)
- .staticmethod("destroy")
- .def("clear", &ImageCacheWrap::clear)
-- .def("attribute", &ImageCacheWrap::attribute)
-+ // .def("attribute", &ImageCacheWrap::attribute)
- .def("attribute", &ImageCacheWrap::attribute_int)
- .def("attribute", &ImageCacheWrap::attribute_float)
-- .def("attribute", &ImageCacheWrap::attribute_double)
-- .def("attribute", &ImageCacheWrap::attribute_char)
-+ // .def("attribute", &ImageCacheWrap::attribute_double)
-+ // .def("attribute", &ImageCacheWrap::attribute_char)
- .def("attribute", &ImageCacheWrap::attribute_string)
-- .def("getattribute", &ImageCacheWrap::attribute)
-+ // .def("getattribute", &ImageCacheWrap::attribute)
- .def("getattribute", &ImageCacheWrap::getattribute_int)
- .def("getattribute", &ImageCacheWrap::getattribute_float)
-- .def("getattribute", &ImageCacheWrap::getattribute_double)
-- .def("getattribute", &ImageCacheWrap::getattribute_char)
-+ // .def("getattribute", &ImageCacheWrap::getattribute_double)
-+ // .def("getattribute", &ImageCacheWrap::getattribute_char)
- .def("getattribute", &ImageCacheWrap::getattribute_string)
-- .def("resolve_filename", &ImageCacheWrap::resolve_filename)
-- .def("get_image_info", &ImageCacheWrap::get_image_info)
-- .def("get_image_info", &ImageCacheWrap::get_image_info_old)
-+ // .def("get_image_info", &ImageCacheWrap::get_image_info)
-+ // .def("get_image_info", &ImageCacheWrap::get_image_info_old)
- .def("get_imagespec", &ImageCacheWrap::get_imagespec)
-- .def("get_pixels", &ImageCacheWrap::get_pixels)
-+ // .def("get_pixels", &ImageCacheWrap::get_pixels)
-+ .def("resolve_filename", &ImageCacheWrap::resolve_filename)
-+
- // .def("get_tile", &ImageCacheWrap::get_tile)
- // .def("release_tile", &ImageCacheWrap::release_tile)
- // .def("tile_pixels", &ImageCacheWrap::tile_pixels)