summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ocaml-CVE-2015-8869.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-02-06 23:18:52 -0500
committerLeo Famulari <leo@famulari.name>2022-02-16 11:57:14 -0500
commitd2bb4847b96e51b71126778bb16daa7674a6690c (patch)
tree30b42d5f903857a55e30fb1756a52c0f475ebc60 /gnu/packages/patches/ocaml-CVE-2015-8869.patch
parent5fffd8352b97295303c4782a5835566338119382 (diff)
downloadguix-patches-d2bb4847b96e51b71126778bb16daa7674a6690c.tar
guix-patches-d2bb4847b96e51b71126778bb16daa7674a6690c.tar.gz
gnu: Remove leftover patch files.base-for-series-11411base-for-series-11410
These patches aren't used anywhere in Guix and we forgot to remove them. * gnu/packages/patches/bash-reproducible-linux-pgrp-pipe.patch, gnu/packages/patches/ghc-monad-par-fix-tests.patch, gnu/packages/patches/glibc-CVE-2018-11236.patch, gnu/packages/patches/glibc-CVE-2018-11237.patch, gnu/packages/patches/glibc-hurd-magic-pid.patch, gnu/packages/patches/grocsvs-dont-use-admiral.patch, gnu/packages/patches/hydra-disable-darcs-test.patch, gnu/packages/patches/inkscape-poppler-0.76.patch, gnu/packages/patches/libvirt-create-machine-cgroup.patch, gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch, gnu/packages/patches/marble-qt-add-qt-headers.patch, gnu/packages/patches/maven-enforcer-api-fix-old-dependencies.patch, gnu/packages/patches/mescc-tools-boot.patch, gnu/packages/patches/nettle-3.5-CVE-2021-3580-pt1.patch, gnu/packages/patches/nettle-3.5-CVE-2021-3580-pt2.patch, gnu/packages/patches/nettle-3.5-check-_pkcs1_sec_decrypt-msg-len.patch, gnu/packages/patches/ocaml-Add-a-.file-directive.patch, gnu/packages/patches/ocaml-CVE-2015-8869.patch, gnu/packages/patches/ocaml-bitstring-fix-configure.patch, gnu/packages/patches/ocaml-enable-ocamldoc-reproducibility.patch, gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch, gnu/packages/patches/openjdk-14-builtins.patch, gnu/packages/patches/openssl-c-rehash-in.patch, gnu/packages/patches/openssl-runpath.patch, gnu/packages/patches/passwordsafe-meson-remove-extra-argument.patch, gnu/packages/patches/patchutils-test-perms.patch, gnu/packages/patches/python-CVE-2018-14647.patch, gnu/packages/patches/python-CVE-2020-26116.patch, gnu/packages/patches/python-axolotl-AES-fix.patch, gnu/packages/patches/python-babel-fix-parse-future-test.patch, gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch, gnu/packages/patches/python-pytest-asyncio-python-3.8.patch, gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch, gnu/packages/patches/qt4-ldflags.patch, gnu/packages/patches/rust-coresimd-doctest.patch, gnu/packages/patches/streamlink-update-test.patch, gnu/packages/patches/tcc-boot-0.9.27.patch, gnu/packages/patches/vtk-8-fix-freetypetools-build-failure.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/ocaml-CVE-2015-8869.patch')
-rw-r--r--gnu/packages/patches/ocaml-CVE-2015-8869.patch72
1 files changed, 0 insertions, 72 deletions
diff --git a/gnu/packages/patches/ocaml-CVE-2015-8869.patch b/gnu/packages/patches/ocaml-CVE-2015-8869.patch
deleted file mode 100644
index 0a4cb34d25..0000000000
--- a/gnu/packages/patches/ocaml-CVE-2015-8869.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-Adapted from upstream commit 659615c7b100a89eafe6253e7a5b9d84d0e8df74,
-this patch omits the upstream changes to 'Changes' and 'VERSION'.
-
-http://seclists.org/oss-sec/2016/q2/170
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8869
-https://github.com/ocaml/ocaml/commit/659615c7b100a89eafe6253e7a5b9d84d0e8df74
----
- byterun/alloc.c | 4 ++--
- byterun/intern.c | 2 +-
- byterun/str.c | 4 ++--
- 3 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/byterun/alloc.c b/byterun/alloc.c
-index 96a21bf..0db9947 100644
---- a/byterun/alloc.c
-+++ b/byterun/alloc.c
-@@ -153,7 +153,7 @@ CAMLexport int caml_convert_flag_list(value list, int *flags)
- /* [size] is a [value] representing number of words (fields) */
- CAMLprim value caml_alloc_dummy(value size)
- {
-- mlsize_t wosize = Int_val(size);
-+ mlsize_t wosize = Long_val(size);
-
- if (wosize == 0) return Atom(0);
- return caml_alloc (wosize, 0);
-@@ -169,7 +169,7 @@ CAMLprim value caml_alloc_dummy_function(value size,value arity)
- /* [size] is a [value] representing number of floats. */
- CAMLprim value caml_alloc_dummy_float (value size)
- {
-- mlsize_t wosize = Int_val(size) * Double_wosize;
-+ mlsize_t wosize = Long_val(size) * Double_wosize;
-
- if (wosize == 0) return Atom(0);
- return caml_alloc (wosize, 0);
-diff --git a/byterun/intern.c b/byterun/intern.c
-index 89d13d1..7b8d049 100644
---- a/byterun/intern.c
-+++ b/byterun/intern.c
-@@ -291,7 +291,7 @@ static void intern_rec(value *dest)
- case OFreshOID:
- /* Refresh the object ID */
- /* but do not do it for predefined exception slots */
-- if (Int_val(Field((value)dest, 1)) >= 0)
-+ if (Long_val(Field((value)dest, 1)) >= 0)
- caml_set_oo_id((value)dest);
- /* Pop item and iterate */
- sp--;
-diff --git a/byterun/str.c b/byterun/str.c
-index 5ad4e29..885772f 100644
---- a/byterun/str.c
-+++ b/byterun/str.c
-@@ -266,7 +266,7 @@ CAMLprim value caml_string_greaterequal(value s1, value s2)
- CAMLprim value caml_blit_string(value s1, value ofs1, value s2, value ofs2,
- value n)
- {
-- memmove(&Byte(s2, Long_val(ofs2)), &Byte(s1, Long_val(ofs1)), Int_val(n));
-+ memmove(&Byte(s2, Long_val(ofs2)), &Byte(s1, Long_val(ofs1)), Long_val(n));
- return Val_unit;
- }
-
-@@ -278,7 +278,7 @@ CAMLprim value caml_fill_string(value s, value offset, value len, value init)
-
- CAMLprim value caml_bitvect_test(value bv, value n)
- {
-- int pos = Int_val(n);
-+ intnat pos = Long_val(n);
- return Val_int(Byte_u(bv, pos >> 3) & (1 << (pos & 7)));
- }
-
---
-2.7.4
-