summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/meson-for-build-rpath.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-19 15:24:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-19 15:24:59 +0200
commita7bc1588e6b8ad4a890d9cc884016f36f92f2e7d (patch)
tree284cc0af9edb74bfafad70b5a6fac9ad8b07b532 /gnu/packages/patches/meson-for-build-rpath.patch
parent8a502c3b60fdd5d8ee0b08e1c9d4c0d7fedc2fda (diff)
parentdf570bf271536399993b39e7ea2ea0452bb6cde4 (diff)
downloadguix-patches-a7bc1588e6b8ad4a890d9cc884016f36f92f2e7d.tar
guix-patches-a7bc1588e6b8ad4a890d9cc884016f36f92f2e7d.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/patches/meson-for-build-rpath.patch')
-rw-r--r--gnu/packages/patches/meson-for-build-rpath.patch33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/patches/meson-for-build-rpath.patch b/gnu/packages/patches/meson-for-build-rpath.patch
index 2151d53565..59249e294d 100644
--- a/gnu/packages/patches/meson-for-build-rpath.patch
+++ b/gnu/packages/patches/meson-for-build-rpath.patch
@@ -4,20 +4,21 @@ meson-build-system.
Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
---- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
-+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
-@@ -391,14 +391,6 @@
- print("Symlink creation does not work on this platform. "
- "Skipping all symlinking.")
- printed_symlink_error = True
-- if os.path.isfile(outname):
-- try:
-- depfixer.fix_rpath(outname, install_rpath, False)
-- except SystemExit as e:
-- if isinstance(e.code, int) and e.code == 0:
-- pass
-- else:
-- raise
-
+--- meson-0.42.0/mesonbuild/minstall.py.orig 2017-09-09 01:49:39.147374148 +0200
++++ meson-0.42.0/mesonbuild/minstall.py 2017-09-09 01:51:01.209134717 +0200
+@@ -436,15 +436,6 @@
+ print("Symlink creation does not work on this platform. "
+ "Skipping all symlinking.")
+ printed_symlink_error = True
+- if os.path.isfile(outname):
+- try:
+- depfixer.fix_rpath(outname, install_rpath, final_path,
+- install_name_mappings, verbose=False)
+- except SystemExit as e:
+- if isinstance(e.code, int) and e.code == 0:
+- pass
+- else:
+- raise
+
def run(args):
- global install_log_file
+ parser = buildparser()