summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/lsh-fix-x11-forwarding.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-05 23:48:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-05 23:48:45 -0400
commit0ec195ff02f2817bc52f9c06b85a89b414b0b28c (patch)
treea0badd05075d0475ff7c3c4658ab13b212211f45 /gnu/packages/patches/lsh-fix-x11-forwarding.patch
parentfb81bd9e0bcd12bd371ec8b87f5ade777995e6c4 (diff)
downloadguix-patches-0ec195ff02f2817bc52f9c06b85a89b414b0b28c.tar
guix-patches-0ec195ff02f2817bc52f9c06b85a89b414b0b28c.tar.gz
gnu: lsh: Fix X11 forwarding.
Fixes <https://issues.guix.gnu.org/24049>. * gnu/packages/patches/lsh-fix-x11-forwarding.patch: Add patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/ssh.scm (lsh)[source]: Apply it. [inputs]: Add libxau. Reported-by: myglc2 <myglc2@gmail.com>
Diffstat (limited to 'gnu/packages/patches/lsh-fix-x11-forwarding.patch')
-rw-r--r--gnu/packages/patches/lsh-fix-x11-forwarding.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/lsh-fix-x11-forwarding.patch b/gnu/packages/patches/lsh-fix-x11-forwarding.patch
new file mode 100644
index 0000000000..fd56a5bafd
--- /dev/null
+++ b/gnu/packages/patches/lsh-fix-x11-forwarding.patch
@@ -0,0 +1,20 @@
+--- a/src/server_x11.c 2016-08-01 11:58:54.714647794 +0200
++++ b/src/server_x11.c 2016-08-01 11:58:46.606563478 +0200
+@@ -151,7 +151,7 @@ DEFINE_COMMAND(open_forwarded_x11)
+ #define X11_MIN_DISPLAY 10
+ #define X11_MAX_DISPLAY 1000
+
+-/* FIXME: Create the /tmp/.X11-unix directory, if needed. Figure out
++/* FIXME: Figure out
+ * if and how we should use /tmp/.X17-lock. Consider using display
+ * "unix:17" instead of just ":17".
+ */
+@@ -253,6 +253,7 @@ open_x11_socket(struct ssh_channel *chan
+
+ old_umask = umask(0077);
+
++ mkdir(X11_SOCKET_DIR, S_IRWXU | S_IRWXG | S_IRWXO | S_ISVTX);
+ old_cd = lsh_pushd(X11_SOCKET_DIR, &dir, 0, 0);
+ if (old_cd < 0)
+ {
+