summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-04-26 09:27:50 -0700
committerVagrant Cascadian <vagrant@debian.org>2021-04-28 16:56:35 -0700
commite7fbf10066e3634ec2d284c07afb4fa625d18574 (patch)
treedafad6be4fa5c2835ab53afd750a19972401f6e2 /gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch
parent9dc1c591a4fe90e823ed69fb52c055b98d4699f6 (diff)
downloadguix-patches-e7fbf10066e3634ec2d284c07afb4fa625d18574.tar
guix-patches-e7fbf10066e3634ec2d284c07afb4fa625d18574.tar.gz
gnu: linux-libre-arm64-generic: Add eDP panel, battery and audio
support for Pinebook Pro. * gnu/packages/linux.scm (linux-libre-5.11-source): Add Pinebook Pro lcd patch. (linux-libre-arm64-generic): Enable audio and battery modules for Pinebook Pro. * gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch')
-rw-r--r--gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch b/gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch
new file mode 100644
index 0000000000..51ab544d5e
--- /dev/null
+++ b/gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch
@@ -0,0 +1,40 @@
+From 3a75704e99a118f2d8a4d70f07781558bde85770 Mon Sep 17 00:00:00 2001
+From: Jian-Hong Pan <jhp@endlessos.org>
+Date: Thu, 24 Sep 2020 14:30:43 +0800
+Subject: [PATCH] arm64: dts: rockchip: disable USB type-c DisplayPort
+
+The cdn-dp sub driver probes the device failed on PINEBOOK Pro.
+
+kernel: cdn-dp fec00000.dp: [drm:cdn_dp_probe [rockchipdrm]] *ERROR* missing extcon or phy
+kernel: cdn-dp: probe of fec00000.dp failed with error -22
+
+Then, the device halts all of the DRM related device jobs. For example,
+the operations: vop_component_ops, vop_component_ops and
+rockchip_dp_component_ops cannot be bound to corresponding devices. So,
+Xorg cannot find the correct DRM device.
+
+The USB type-C DisplayPort does not work for now. So, disable the
+DisplayPort node until the type-C phy work has been done.
+
+Link: https://patchwork.kernel.org/patch/11794141/#23639877
+Signed-off-by: Jian-Hong Pan <jhp@endlessos.org>
+---
+ arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts b/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts
+index 219b7507a10f..45769764425d 100644
+--- a/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts
++++ b/arch/arm64/boot/dts/rockchip/rk3399-pinebook-pro.dts
+@@ -380,7 +380,7 @@
+ };
+
+ &cdn_dp {
+- status = "okay";
++ status = "disabled";
+ };
+
+ &cpu_b0 {
+--
+2.30.2
+