summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libofa-ftbfs-2.diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 09:16:01 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:32 +0200
commit38375ce952902931f626ce6440368dee1ff4f68c (patch)
treee5ff640fe9b07d363030055086ac76f4b13f926d /gnu/packages/patches/libofa-ftbfs-2.diff
parent502114de11aa6590bdbe8edfff5a6337d39a1e39 (diff)
downloadguix-patches-38375ce952902931f626ce6440368dee1ff4f68c.tar
guix-patches-38375ce952902931f626ce6440368dee1ff4f68c.tar.gz
gnu: Add libofa.
* gnu/packages/audio.scm (libofa): New variable. * gnu/packages/patches/libofa-ftbfs-1.diff: New file. * gnu/packages/patches/libofa-curl.diff: New file. * gnu/packages/patches/libofa-ftbfs-2.diff: New file. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/patches/libofa-ftbfs-2.diff')
-rw-r--r--gnu/packages/patches/libofa-ftbfs-2.diff27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/libofa-ftbfs-2.diff b/gnu/packages/patches/libofa-ftbfs-2.diff
new file mode 100644
index 0000000000..ad61573578
--- /dev/null
+++ b/gnu/packages/patches/libofa-ftbfs-2.diff
@@ -0,0 +1,27 @@
+Description: ftbfs with GCC-4.7. (Closes: #667250)
+Author: Matthias Klose <doko@debian.org>
+Last-Update: 2012-04-17
+Index: libofa-0.9.3/examples/uselame.cpp
+===================================================================
+--- libofa-0.9.3.orig/examples/uselame.cpp
++++ libofa-0.9.3/examples/uselame.cpp
+@@ -11,6 +11,7 @@
+ #include "windows.h"
+ #else
+ #include <sys/wait.h>
++#include <unistd.h>
+ #endif
+
+ AudioData *loadWaveFile(char *file);
+Index: libofa-0.9.3/examples/wavefile.cpp
+===================================================================
+--- libofa-0.9.3.orig/examples/wavefile.cpp
++++ libofa-0.9.3/examples/wavefile.cpp
+@@ -11,6 +11,7 @@
+ #include "io.h"
+ #endif
+ #include <fcntl.h>
++#include <unistd.h>
+
+ static bool readBytes(int fd, unsigned char *buf, int size) {
+ int ct = 0;