summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libofa-ftbfs-1.diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 09:16:01 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:32 +0200
commit38375ce952902931f626ce6440368dee1ff4f68c (patch)
treee5ff640fe9b07d363030055086ac76f4b13f926d /gnu/packages/patches/libofa-ftbfs-1.diff
parent502114de11aa6590bdbe8edfff5a6337d39a1e39 (diff)
downloadguix-patches-38375ce952902931f626ce6440368dee1ff4f68c.tar
guix-patches-38375ce952902931f626ce6440368dee1ff4f68c.tar.gz
gnu: Add libofa.
* gnu/packages/audio.scm (libofa): New variable. * gnu/packages/patches/libofa-ftbfs-1.diff: New file. * gnu/packages/patches/libofa-curl.diff: New file. * gnu/packages/patches/libofa-ftbfs-2.diff: New file. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/patches/libofa-ftbfs-1.diff')
-rw-r--r--gnu/packages/patches/libofa-ftbfs-1.diff45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/patches/libofa-ftbfs-1.diff b/gnu/packages/patches/libofa-ftbfs-1.diff
new file mode 100644
index 0000000000..4aa712320c
--- /dev/null
+++ b/gnu/packages/patches/libofa-ftbfs-1.diff
@@ -0,0 +1,45 @@
+Description: fix FTBFS with GCC 4.3. (Closes: #417355)
+Author: Martin Michlmayr <tbm@cyrius.com>
+Last-Update: 2007-04-02
+
+Description: add a missing include. (Closes: #441557)
+Author: Brian M. Carlson <sandals@crustytoothpaste.ath.cx>
+Last-Update: 2007-12-29
+
+Index: libofa-0.9.3/lib/signal_op.cpp
+===================================================================
+--- libofa-0.9.3.orig/lib/signal_op.cpp
++++ libofa-0.9.3/lib/signal_op.cpp
+@@ -12,6 +12,7 @@
+ // DATE CREATED: 1/12/06
+
+
++#include <cstdlib>
+ #include <math.h>
+ #include "signal_op.h"
+ #include "AFLIB/aflibConverter.h"
+Index: libofa-0.9.3/examples/example.cpp
+===================================================================
+--- libofa-0.9.3.orig/examples/example.cpp
++++ libofa-0.9.3/examples/example.cpp
+@@ -8,6 +8,8 @@
+ -------------------------------------------------------------------*/
+
+ #include "protocol.h"
++#include <cctype>
++#include <string.h>
+
+ AudioData* loadWaveFile(char *file);
+ AudioData* loadDataUsingLAME(char *file);
+Index: libofa-0.9.3/examples/protocol.cpp
+===================================================================
+--- libofa-0.9.3.orig/examples/protocol.cpp
++++ libofa-0.9.3/examples/protocol.cpp
+@@ -8,6 +8,7 @@
+ -------------------------------------------------------------------*/
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstring>
+ #include <string>
+ #include <map>
+ #include <expat.h>