summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libmp4v2-c++11.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
commitd1f3b333e6176a7879ab3742bbebb2a99f61a528 (patch)
tree8bd82ce68bd2534a48bf13c7256997f82dd1b3f4 /gnu/packages/patches/libmp4v2-c++11.patch
parente01d384efcdaf564bbb221e43b81e087c8e2af06 (diff)
parent861907f01efb1cae7f260e8cb7b991d5034a486a (diff)
downloadguix-patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar
guix-patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/libmp4v2-c++11.patch')
-rw-r--r--gnu/packages/patches/libmp4v2-c++11.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/libmp4v2-c++11.patch b/gnu/packages/patches/libmp4v2-c++11.patch
new file mode 100644
index 0000000000..e12f89bd84
--- /dev/null
+++ b/gnu/packages/patches/libmp4v2-c++11.patch
@@ -0,0 +1,14 @@
+Avoid a type mismatch that shows up in C++11.
+Taken from <https://bugs.debian.org/853560>.
+
+--- a/src/rtphint.cpp 2012-05-20 16:11:53.000000000 -0600
++++ b/src/rtphint.cpp 2017-05-16 10:25:26.930705191 -0600
+@@ -339,7 +339,7 @@
+ pSlash = strchr(pSlash, '/');
+ if (pSlash != NULL) {
+ pSlash++;
+- if (pSlash != '\0') {
++ if (*pSlash != '\0') {
+ length = (uint32_t)strlen(pRtpMap) - (pSlash - pRtpMap);
+ *ppEncodingParams = (char *)MP4Calloc(length + 1);
+ strncpy(*ppEncodingParams, pSlash, length);