summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch
diff options
context:
space:
mode:
authormuradm <mail@muradm.net>2021-09-17 09:26:48 +0300
committerLudovic Courtès <ludo@gnu.org>2021-09-18 12:09:40 +0200
commite8d80d045660973b12ae49dc1b71b2f5641ab92e (patch)
treed6ca7776d9df8d1e956cb68f90f72aebec228cc6 /gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch
parentc3892d4ffb0fc52d5a6a503f358f06768a7636e8 (diff)
downloadguix-patches-e8d80d045660973b12ae49dc1b71b2f5641ab92e.tar
guix-patches-e8d80d045660973b12ae49dc1b71b2f5641ab92e.tar.gz
gnu: gnunet: Fix libmicrohttpd test case using SSL3.
* gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch: Patch for failing test case as suggested by libmicrohttpd mailing list * gnu/packages/gnunet.scm (libmicrohttpd): use patch * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch')
-rw-r--r--gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch b/gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch
new file mode 100644
index 0000000000..e8d5dce0ed
--- /dev/null
+++ b/gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch
@@ -0,0 +1,35 @@
+ Disable usage of SSLv3 in testing
+
+ Integrated uptream version 0.9.74
+
+
+diff --git a/src/testcurl/https/test_tls_options.c b/src/testcurl/https/test_tls_options.c
+
+--- a/src/testcurl/https/test_tls_options.c
++++ b/src/testcurl/https/test_tls_options.c
+@@ -119,11 +119,6 @@ main (int argc, char *const *argv)
+ fprintf (stderr, "Curl does not support SSL. Cannot run the test.\n");
+ return 77;
+ }
+- if (0 != strncmp (ssl_version, "GnuTLS", 6))
+- {
+- fprintf (stderr, "This test can be run only with libcurl-gnutls.\n");
+- return 77;
+- }
+
+ if (! testsuite_curl_global_init ())
+ return 99;
+@@ -152,10 +147,10 @@ main (int argc, char *const *argv)
+ fprintf (stderr,
+ "The following handshake should fail (and print an error message)...\n");
+ if (0 !=
+- test_wrap ("TLS1.0 vs SSL3",
++ test_wrap ("TLS1.1 vs TLS1.0",
+ &test_unmatching_ssl_version, NULL, port, daemon_flags,
+ aes256_sha,
+- CURL_SSLVERSION_SSLv3,
++ CURL_SSLVERSION_TLSv1_1,
+ MHD_OPTION_HTTPS_MEM_KEY, srv_key_pem,
+ MHD_OPTION_HTTPS_MEM_CERT, srv_self_signed_cert_pem,
+ MHD_OPTION_HTTPS_PRIORITIES,
+