summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ledger-fix-uninitialized.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-11 14:22:50 -0800
committerLeo Famulari <leo@famulari.name>2018-01-11 14:22:50 -0800
commit4adb40bffc0dda8871878283887a0e0cd88d9578 (patch)
tree74d5fb686116002da72de4a1075d0ed8f307cec1 /gnu/packages/patches/ledger-fix-uninitialized.patch
parent4610ab7c9a5327df0d475262817bc081a5891aa8 (diff)
parent138c08899ba73049de8afd2b74a8cf6845a1d9e1 (diff)
downloadguix-patches-4adb40bffc0dda8871878283887a0e0cd88d9578.tar
guix-patches-4adb40bffc0dda8871878283887a0e0cd88d9578.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/ledger-fix-uninitialized.patch')
-rw-r--r--gnu/packages/patches/ledger-fix-uninitialized.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/ledger-fix-uninitialized.patch b/gnu/packages/patches/ledger-fix-uninitialized.patch
new file mode 100644
index 0000000000..128c90ec13
--- /dev/null
+++ b/gnu/packages/patches/ledger-fix-uninitialized.patch
@@ -0,0 +1,27 @@
+This fixes failures of tests "BaseLine_opt-datetime-format" and
+"BaseLine_opt-time-report", which were printing an unexpected trailing '*' on
+the last line of output, e.g.:
+
+ @@ -5,4 +5,4 @@
+ 04/05/13 12:00 PM 04/05/13 01:30 PM 1.50h Lunch
+ 04/05/13 11:30 AM 04/05/13 12:00 PM 30.0m Walk
+ --------------------------------------------------
+ -
+ + *
+
+Reported upstream at
+https://groups.google.com/d/msg/ledger-cli/EeJUrUk8YDc/pIR-LOTVEAAJ
+
+diff --git a/src/account.h b/src/account.h
+index 1b97463d..f2555593 100644
+--- a/src/account.h
++++ b/src/account.h
+@@ -187,7 +187,7 @@ public:
+
+ datetime_t earliest_checkin;
+ datetime_t latest_checkout;
+- bool latest_checkout_cleared;
++ bool latest_checkout_cleared = false;
+
+ std::set<path> filenames;
+ std::set<string> accounts_referenced;