summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ldc-disable-tests.patch
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public01@thebird.nl>2018-02-18 06:09:44 +0000
committerDanny Milosavljevic <dannym@scratchpost.org>2018-02-20 19:36:34 +0100
commit1b541c3e9375952f4d58dec3783eea2316c65967 (patch)
treeed54107a139e07dbdf15d918c839a2090b5464fd /gnu/packages/patches/ldc-disable-tests.patch
parent5dd53cbf560f784577b3c22ac9e15e08e35566b5 (diff)
downloadguix-patches-1b541c3e9375952f4d58dec3783eea2316c65967.tar
guix-patches-1b541c3e9375952f4d58dec3783eea2316c65967.tar.gz
gnu: ldc: Update to 1.7.0.
Fixes recent bootstrap and updates ldc and package manager to match. * gnu/packages/ldc.scm (ldc-bootstrap): Update to 0.17.4. [properties]: Add max-slient-time. [arguments]<#:phases>[patch-phobos]: Update patches (see below). (ldc): Update to 1.7.0. (ldc-beta): Delete variable. [arguments]<#:phases>[patch-phobos]: Update patches (see below). [arguments]<#:phases>[check]: Use invoke. (rdmd): Update to 2.077.1. (dub): Update to 1.7.2. * gnu/local.mk (dist_patch_DATA): Remove "ldc-disable-tests.patch". Add "ldc-bootstrap-disable-tests.patch". Remove "ldc-1.1.0-disable-phobos-tests.patch". Add "ldc-1.7.0-disable-phobos-tests.patch". Remove "ldc-1.1.0-disable-dmd-tests.patch". Co-Authored-By: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/patches/ldc-disable-tests.patch')
-rw-r--r--gnu/packages/patches/ldc-disable-tests.patch74
1 files changed, 0 insertions, 74 deletions
diff --git a/gnu/packages/patches/ldc-disable-tests.patch b/gnu/packages/patches/ldc-disable-tests.patch
deleted file mode 100644
index bdd6e5b76c..0000000000
--- a/gnu/packages/patches/ldc-disable-tests.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-This patch fixes a failing unit test by feeding buildNormalizedPath to the
-tzdata properly. Three other tests are disabled, one assumes /root and the
-two others use networking. Not bad out of almost 700 tests!
-
-by Pjotr Prins <pjotr.guix@thebird.nl>
-
---- a/std/datetime.d.orig 2016-11-24 01:13:52.584495545 +0100
-+++ b/std/datetime.d 2016-11-24 01:17:09.655306728 +0100
-@@ -28081,22 +28081,24 @@
- import std.range : retro;
- import std.format : format;
-
-- name = strip(name);
--
- enforce(tzDatabaseDir.exists(), new DateTimeException(format("Directory %s does not exist.", tzDatabaseDir)));
- enforce(tzDatabaseDir.isDir, new DateTimeException(format("%s is not a directory.", tzDatabaseDir)));
-
- version(Android)
- {
-+ name = strip(name);
- auto tzfileOffset = name in tzdataIndex(tzDatabaseDir);
- enforce(tzfileOffset, new DateTimeException(format("The time zone %s is not listed.", name)));
- string tzFilename = separate_index ? "zoneinfo.dat" : "tzdata";
- immutable file = buildNormalizedPath(tzDatabaseDir, tzFilename);
- }
- else
-- immutable file = buildNormalizedPath(tzDatabaseDir, name);
-+ {
-+ auto filename = "./" ~ strip(name); // make sure the prefix is not stripped
-+ immutable file = buildNormalizedPath(tzDatabaseDir, filename);
-+ }
-
-- enforce(file.exists(), new DateTimeException(format("File %s does not exist.", file)));
-+ enforce(file.exists(), new DateTimeException(format("File %s does not exist in %s.", file, tzDatabaseDir)));
- enforce(file.isFile, new DateTimeException(format("%s is not a file.", file)));
-
- auto tzFile = File(file);
-diff --git a/std/path.d b/std/path.d
-index 254d8f0..b0fc04d 100644
---- a/std/path.d
-+++ b/std/path.d
-@@ -3080,8 +3080,11 @@ unittest
- }
- else
- {
-+ pragma(msg, "test disabled on GNU Guix");
-+/*
- assert(expandTilde("~root") == "/root", expandTilde("~root"));
- assert(expandTilde("~root/") == "/root/", expandTilde("~root/"));
-+*/
- }
- assert(expandTilde("~Idontexist/hey") == "~Idontexist/hey");
- }
-diff --git a/std/socket.d b/std/socket.d
-index b85d1c9..7fbf346 100644
---- a/std/socket.d
-+++ b/std/socket.d
-@@ -859,6 +862,8 @@ class InternetHost
-
- unittest
- {
-+ pragma(msg, "test disabled on GNU Guix");
-+ /*
- InternetHost ih = new InternetHost;
-
- ih.getHostByAddr(0x7F_00_00_01);
-@@ -889,6 +894,7 @@ unittest
- // writefln("aliases[%d] = %s", i, s);
- // }
- });
-+ */
- }
-
-