summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/kpmcore-fix-tests.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-17 19:17:19 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-18 01:59:19 +0200
commit5db3f6c18152f7f3a724cdbca50dcedea4389079 (patch)
treebc2ad662a9049e192356dc1d74d492e9e04e38fe /gnu/packages/patches/kpmcore-fix-tests.patch
parent565d2eb0fe39d1a8dca70a43e063f50d56fb4640 (diff)
downloadguix-patches-5db3f6c18152f7f3a724cdbca50dcedea4389079.tar
guix-patches-5db3f6c18152f7f3a724cdbca50dcedea4389079.tar.gz
gnu: kpmcore: Update to 4.1.0.
* gnu/packages/patches/kpmcore-fix-tests.patch, gnu/packages/patches/kpmcore-remove-broken-test.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/kde.scm (kpmcore): Update to 4.1.0. [source](patches): Remove.
Diffstat (limited to 'gnu/packages/patches/kpmcore-fix-tests.patch')
-rw-r--r--gnu/packages/patches/kpmcore-fix-tests.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/patches/kpmcore-fix-tests.patch b/gnu/packages/patches/kpmcore-fix-tests.patch
deleted file mode 100644
index 12043abe72..0000000000
--- a/gnu/packages/patches/kpmcore-fix-tests.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Git commit c02d59aa6d314678cef9683f96b28e2a1abd82b7 by Andrius Štikonas, on behalf of Hartmut Goebel.
-Committed on 07/11/2019 at 22:16.
-Pushed by stikonas into branch '4.0'.
-
-Fix test for kpmcore: stop helper only if formerly started.
-
-See https://bugs.kde.org/413851 and https://phabricator.kde.org/D25161
-
-diff --git a/src/util/externalcommand.cpp b/src/util/externalcommand.cpp
---- a/src/util/externalcommand.cpp
-+++ b/src/util/externalcommand.cpp
-@@ -433,14 +433,17 @@
-
- void ExternalCommand::stopHelper()
- {
-+ if (!helperStarted)
-+ return;
- auto *interface = new org::kde::kpmcore::externalcommand(QStringLiteral("org.kde.kpmcore.externalcommand"),
- QStringLiteral("/Helper"), QDBusConnection::systemBus());
- QByteArray request;
- const quint64 nonce = interface->getNonce();
- request.setNum(nonce);
- QByteArray hash = QCryptographicHash::hash(request, QCryptographicHash::Sha512);
- interface->exit(privateKey->signMessage(hash, QCA::EMSA3_Raw), nonce);
-
-+ helperStarted = false;
- delete privateKey;
- delete init;
- }
-