summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/khal-disable-failing-tests.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-06 17:14:41 -0500
committerLeo Famulari <leo@famulari.name>2017-01-06 17:14:41 -0500
commit74288230ea8b2310495dc2739f39ceadcc143fd0 (patch)
tree73ba6c7c13d59c5f92b409c94dccfff159e08f4d /gnu/packages/patches/khal-disable-failing-tests.patch
parent92e779592d269ca1924f184496eb4ca832997b12 (diff)
parentaa21c764d65068783ae31febee2a92eb3d138a24 (diff)
downloadguix-patches-74288230ea8b2310495dc2739f39ceadcc143fd0.tar
guix-patches-74288230ea8b2310495dc2739f39ceadcc143fd0.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/khal-disable-failing-tests.patch')
-rw-r--r--gnu/packages/patches/khal-disable-failing-tests.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/khal-disable-failing-tests.patch b/gnu/packages/patches/khal-disable-failing-tests.patch
new file mode 100644
index 0000000000..e2c65df8ce
--- /dev/null
+++ b/gnu/packages/patches/khal-disable-failing-tests.patch
@@ -0,0 +1,33 @@
+Disable some tests that are known to fail:
+
+https://github.com/pimutils/khal/issues/546
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=844081
+
+diff --git a/tests/khalendar_test.py b/tests/khalendar_test.py
+index fd8dcc6..17732bf 100644
+--- a/tests/khalendar_test.py
++++ b/tests/khalendar_test.py
+@@ -65,6 +65,7 @@ class TestCalendar(object):
+ else:
+ mtimes[cal] = mtime
+
++ @pytest.mark.xfail
+ def test_db_needs_update(self, coll_vdirs):
+ coll, vdirs = coll_vdirs
+
+@@ -321,6 +322,7 @@ class TestDbCreation(object):
+ CalendarCollection(calendars, dbpath=dbpath, locale=aux.locale)
+
+
++@pytest.mark.xfail
+ def test_default_calendar(coll_vdirs):
+ """test if an update to the vdir is detected by the CalendarCollection"""
+ coll, vdirs = coll_vdirs
+@@ -341,6 +343,7 @@ def test_default_calendar(coll_vdirs):
+ assert len(list(coll.get_events_on(today))) == 0
+
+
++@pytest.mark.xfail
+ def test_only_update_old_event(coll_vdirs, monkeypatch):
+ coll, vdirs = coll_vdirs
+