summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/isl-0.11.1-aarch64-support.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-24 13:33:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-07 12:26:44 +0300
commit2ff746dcd26c21af4cb281074f1a3b6d378ed455 (patch)
treee558a429f358afe939b4eb37a2f090bf8b048294 /gnu/packages/patches/isl-0.11.1-aarch64-support.patch
parent21e5e1e070339a8a377ae8df017603fff1ac7b45 (diff)
downloadguix-patches-2ff746dcd26c21af4cb281074f1a3b6d378ed455.tar
guix-patches-2ff746dcd26c21af4cb281074f1a3b6d378ed455.tar.gz
gnu: isl: Add support for aarch64.
* gnu/packages/gcc.scm (isl)[source]: Add patch. * gnu/packages/patches/isl-0.11.1-aarch64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/isl-0.11.1-aarch64-support.patch')
-rw-r--r--gnu/packages/patches/isl-0.11.1-aarch64-support.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/isl-0.11.1-aarch64-support.patch b/gnu/packages/patches/isl-0.11.1-aarch64-support.patch
new file mode 100644
index 0000000000..c5607fc80d
--- /dev/null
+++ b/gnu/packages/patches/isl-0.11.1-aarch64-support.patch
@@ -0,0 +1,40 @@
+Add aarch64 support to config.guess and config.sub, as would be found if using
+a more recent version of autoconf.
+---
+ config.guess | 7 +++++++
+ config.sub | 1 +
+ 2 files changed, 8 insertions(+)
+
+diff --git a/config.guess b/config.guess
+index 40eaed4..baad294 100755
+--- a/config.guess
++++ b/config.guess
+@@ -861,6 +861,13 @@ EOF
+ i*86:Minix:*:*)
+ echo ${UNAME_MACHINE}-pc-minix
+ exit ;;
++ aarch64:Linux:*:*)
++ echo ${UNAME_MACHINE}-unknown-linux-gnu
++ exit ;;
++ aarch64_be:Linux:*:*)
++ UNAME_MACHINE=aarch64_be
++ echo ${UNAME_MACHINE}-unknown-linux-gnu
++ exit ;;
+ alpha:Linux:*:*)
+ case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
+ EV5) UNAME_MACHINE=alphaev5 ;;
+diff --git a/config.sub b/config.sub
+index 30fdca8..8f5b018 100755
+--- a/config.sub
++++ b/config.sub
+@@ -247,6 +247,7 @@ case $basic_machine in
+ # Some are omitted here because they have special meanings below.
+ 1750a | 580 \
+ | a29k \
++ | aarch64 | aarch64_be \
+ | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
+ | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
+ | am33_2.0 \
+--
+2.9.0
+