summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/hurd-cross.patch
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-08 14:07:51 -0400
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 12:59:33 +0100
commit496d607db3cf1e438ffd1526c4153be551bbef50 (patch)
treeb43f7dd1db7c5bebf5f3487ea990f62e8d1f9b1e /gnu/packages/patches/hurd-cross.patch
parentaaa4cb0caddd594188153da37d3eb9509de90289 (diff)
downloadguix-patches-496d607db3cf1e438ffd1526c4153be551bbef50.tar
guix-patches-496d607db3cf1e438ffd1526c4153be551bbef50.tar.gz
gnu: hurd: Update to hurd-headers version: 0.9-91a51672.
* gnu/packages/patches/hurd-cross.patch: New file. * gnu/packages/patches/hurd-fix-eth-multiplexer-dependency.patch: Remove unused file. * gnu/local.mk (dist_patch_DATA): Update admin. * gnu/packages/hurd.scm (hurd): Update to latest git master: version and source from hurd-headers; Add hurd-cross patch.
Diffstat (limited to 'gnu/packages/patches/hurd-cross.patch')
-rw-r--r--gnu/packages/patches/hurd-cross.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/hurd-cross.patch b/gnu/packages/patches/hurd-cross.patch
new file mode 100644
index 0000000000..cc95dddccc
--- /dev/null
+++ b/gnu/packages/patches/hurd-cross.patch
@@ -0,0 +1,33 @@
+This fixes linking libfstest/test-fcntl (and others).
+
+As discussed with upstream: https://lists.gnu.org/archive/html/bug-hurd/2020-03/msg00018.html
+
+From 96a9f67a8685e713f25259c18306797d54cc27a5 Mon Sep 17 00:00:00 2001
+From: Jan Nieuwenhuizen <janneke@gnu.org>
+Date: Sat, 14 Mar 2020 11:28:31 +0100
+Subject: [PATCH] build: Fix cross build on Guix.
+
+As discussed in https://lists.gnu.org/archive/html/bug-hurd/2020-03/msg00018.html.
+
+* Makeconf (lpath): Add -Wl,-rpath-link=<dir> next to -L<dir>.
+---
+ Makeconf | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makeconf b/Makeconf
+index 67f7ab1c..f68ff6e3 100644
+--- a/Makeconf
++++ b/Makeconf
+@@ -325,7 +325,8 @@ _libsubst=${libsubst$(patsubst %,-override,${libsubst-override})}
+
+ # Direct the linker where to find shared objects specified in the
+ # dependencies of other shared objects it encounters.
+-lpath := -L. $(patsubst %,-L%,$(dir $(wildcard ../lib*/lib*.so)))
++lib_dirs := $(dir $(wildcard ../lib*/lib*.so))
++lpath := -L. $(lib_dirs:%=-L%) $(lib_dirs:%=-Wl,-rpath-link=%)
+
+ # Main rule to link executables
+ #
+--
+2.24.0
+