summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-relocatable.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-18 14:07:17 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-18 15:31:12 +0200
commit920f2c42ce3345dc1355a41377ebf01a33fdae51 (patch)
tree0b82a81963399bf50244ed96aa24fdce660ed935 /gnu/packages/patches/guile-relocatable.patch
parent44455ab95187b029d551d5c4d5a89ea07efc9d69 (diff)
downloadguix-patches-920f2c42ce3345dc1355a41377ebf01a33fdae51.tar
guix-patches-920f2c42ce3345dc1355a41377ebf01a33fdae51.tar.gz
gnu: guile: Make relocatable patch version-independent.
* gnu/packages/patches/guile-relocatable.patch: Use SCM_EFFECTIVE_VERSION instead of "2.0".
Diffstat (limited to 'gnu/packages/patches/guile-relocatable.patch')
-rw-r--r--gnu/packages/patches/guile-relocatable.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/patches/guile-relocatable.patch b/gnu/packages/patches/guile-relocatable.patch
index 2431495f24..95bddcce88 100644
--- a/gnu/packages/patches/guile-relocatable.patch
+++ b/gnu/packages/patches/guile-relocatable.patch
@@ -35,11 +35,11 @@ location of the `guile' binary, allowing it to be relocated.
+
+ module_dir = scm_gc_malloc_pointerless (strlen (prefix) + 50, "string");
+ strcpy (module_dir, prefix);
-+ strcat (module_dir, "/share/guile/2.0");
++ strcat (module_dir, "/share/guile/" SCM_EFFECTIVE_VERSION);
+
+ ccache_dir = scm_gc_malloc_pointerless (strlen (prefix) + 50, "string");
+ strcpy (ccache_dir, prefix);
-+ strcat (ccache_dir, "/lib/guile/2.0/ccache");
++ strcat (ccache_dir, "/lib/guile/" SCM_EFFECTIVE_VERSION "/ccache");
+
env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_PATH"));
if (env && strcmp (env, "") == 0)