summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnutls-CVE-2021-20232.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-06 00:10:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-06 00:50:16 -0400
commit63858f8c8bbcacddbe54f178942975d96b21fe3e (patch)
treed73d94ccd05f0e3884816de3c9279b10e450566a /gnu/packages/patches/gnutls-CVE-2021-20232.patch
parentf72a1253a18798a25245b4124c1da35ed993e0d1 (diff)
downloadguix-patches-63858f8c8bbcacddbe54f178942975d96b21fe3e.tar
guix-patches-63858f8c8bbcacddbe54f178942975d96b21fe3e.tar.gz
gnu: gnutls: Update to 3.7.2.
The 3.7 branch, while not considered the "stable" branch upstream, has been adopted by most major GNU/Linux distributions such as Debian, Arch, openSUSE, etc. It has the benefit of receiving all the security fixes. * gnu/packages/tls.scm (gnutls): Update to 3.7.2. Remove trailing #t. [source]: Remove the gnutls-CVE-2021-20231.patch and gnutls-CVE-2021-20232.patch patches, now incorporated in the source. * gnu/packages/patches/gnutls-CVE-2021-20231.patch: Delete file. * gnu/packages/patches/gnutls-CVE-2021-20232.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register them.
Diffstat (limited to 'gnu/packages/patches/gnutls-CVE-2021-20232.patch')
-rw-r--r--gnu/packages/patches/gnutls-CVE-2021-20232.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/gnu/packages/patches/gnutls-CVE-2021-20232.patch b/gnu/packages/patches/gnutls-CVE-2021-20232.patch
deleted file mode 100644
index dc3a0be690..0000000000
--- a/gnu/packages/patches/gnutls-CVE-2021-20232.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 75a937d97f4fefc6f9b08e3791f151445f551cb3 Mon Sep 17 00:00:00 2001
-From: Daiki Ueno <ueno@gnu.org>
-Date: Fri, 29 Jan 2021 14:06:23 +0100
-Subject: [PATCH 2/2] pre_shared_key: avoid use-after-free around realloc
-
-Signed-off-by: Daiki Ueno <ueno@gnu.org>
----
- lib/ext/pre_shared_key.c | 15 ++++++++++++---
- 1 file changed, 12 insertions(+), 3 deletions(-)
-
-diff --git a/lib/ext/pre_shared_key.c b/lib/ext/pre_shared_key.c
-index a042c6488..380bf39ed 100644
---- a/lib/ext/pre_shared_key.c
-+++ b/lib/ext/pre_shared_key.c
-@@ -267,7 +267,7 @@ client_send_params(gnutls_session_t session,
- size_t spos;
- gnutls_datum_t username = {NULL, 0};
- gnutls_datum_t user_key = {NULL, 0}, rkey = {NULL, 0};
-- gnutls_datum_t client_hello;
-+ unsigned client_hello_len;
- unsigned next_idx;
- const mac_entry_st *prf_res = NULL;
- const mac_entry_st *prf_psk = NULL;
-@@ -428,8 +428,7 @@ client_send_params(gnutls_session_t session,
- assert(extdata->length >= sizeof(mbuffer_st));
- assert(ext_offset >= (ssize_t)sizeof(mbuffer_st));
- ext_offset -= sizeof(mbuffer_st);
-- client_hello.data = extdata->data+sizeof(mbuffer_st);
-- client_hello.size = extdata->length-sizeof(mbuffer_st);
-+ client_hello_len = extdata->length-sizeof(mbuffer_st);
-
- next_idx = 0;
-
-@@ -440,6 +439,11 @@ client_send_params(gnutls_session_t session,
- }
-
- if (prf_res && rkey.size > 0) {
-+ gnutls_datum_t client_hello;
-+
-+ client_hello.data = extdata->data+sizeof(mbuffer_st);
-+ client_hello.size = client_hello_len;
-+
- ret = compute_psk_binder(session, prf_res,
- binders_len, binders_pos,
- ext_offset, &rkey, &client_hello, 1,
-@@ -474,6 +478,11 @@ client_send_params(gnutls_session_t session,
- }
-
- if (prf_psk && user_key.size > 0 && info) {
-+ gnutls_datum_t client_hello;
-+
-+ client_hello.data = extdata->data+sizeof(mbuffer_st);
-+ client_hello.size = client_hello_len;
-+
- ret = compute_psk_binder(session, prf_psk,
- binders_len, binders_pos,
- ext_offset, &user_key, &client_hello, 0,
---
-2.30.2
-