summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ghostscript-runpath.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-05 15:23:11 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-05 15:23:11 +0200
commit1d386b2d711fee2dc618358ac51b1865e3f85433 (patch)
tree3b36985e53fbb237963f3f024c43768860fdc7da /gnu/packages/patches/ghostscript-runpath.patch
parentc17b2adf541d24dab357f54b62e6399800534313 (diff)
downloadguix-patches-1d386b2d711fee2dc618358ac51b1865e3f85433.tar
guix-patches-1d386b2d711fee2dc618358ac51b1865e3f85433.tar.gz
gnu: ghostscript: Add $libdir to the RUNPATH of executables.
Fixes <http://bugs.gnu.org/20050>. Reported by taylanbayirli@gmail.com (Taylan Ulrich Bayırlı/Kammer). * gnu/packages/patches/ghostscript-runpath.patch: New file. * gnu/packages/ghostscript.scm (ghostscript)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/ghostscript-runpath.patch')
-rw-r--r--gnu/packages/patches/ghostscript-runpath.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/ghostscript-runpath.patch b/gnu/packages/patches/ghostscript-runpath.patch
new file mode 100644
index 0000000000..c7dcfd4529
--- /dev/null
+++ b/gnu/packages/patches/ghostscript-runpath.patch
@@ -0,0 +1,17 @@
+This patch adds $(libdir) to the RUNPATH of 'gsc' and 'gsx'.
+
+--- gnu-ghostscript-9.14.0/base/unix-dll.mak 2015-04-05 15:12:45.386957927 +0200
++++ gnu-ghostscript-9.14.0/base/unix-dll.mak 2015-04-05 15:12:49.222982359 +0200
+@@ -91,11 +91,11 @@ $(GS_SO_MAJOR): $(GS_SO_MAJOR_MINOR)
+ # Build the small Ghostscript loaders, with Gtk+ and without
+ $(GSSOC_XE): $(GS_SO) $(PSSRC)$(SOC_LOADER)
+ $(GLCC) -g -o $(GSSOC_XE) $(PSSRC)dxmainc.c \
+- -L$(BINDIR) -l$(GS_SO_BASE)
++ -L$(BINDIR) -l$(GS_SO_BASE) -Wl,-rpath=$(libdir)
+
+ $(GSSOX_XE): $(GS_SO) $(PSSRC)$(SOC_LOADER)
+ $(GLCC) -g $(SOC_CFLAGS) -o $(GSSOX_XE) $(PSSRC)$(SOC_LOADER) \
+- -L$(BINDIR) -l$(GS_SO_BASE) $(SOC_LIBS)
++ -L$(BINDIR) -l$(GS_SO_BASE) $(SOC_LIBS) -Wl,-rpath=$(libdir)
+
+ # ------------------------- Recursive make targets ------------------------- #