summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ghostscript-freetype-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-08 22:18:30 +0100
committerMarius Bakke <marius@gnu.org>2020-12-08 22:57:53 +0100
commit9337c16cb69fd47ca31ebe184d2a37028b978249 (patch)
tree7b27526b99a20a3f34f7ad66fadcb4da1c58db34 /gnu/packages/patches/ghostscript-freetype-compat.patch
parent18f10c0b12dd369507fd2821dcf748fc9b13053a (diff)
downloadguix-patches-9337c16cb69fd47ca31ebe184d2a37028b978249.tar
guix-patches-9337c16cb69fd47ca31ebe184d2a37028b978249.tar.gz
gnu: ghostscript: Fix build with FreeType 2.10.4.
This fixes a build failure from 79b31767d084a2feeb2edcb41ae863a0d534b847. * gnu/packages/patches/ghostscript-freetype-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/ghostscript.scm (ghostscript)[source](patches): Add it.
Diffstat (limited to 'gnu/packages/patches/ghostscript-freetype-compat.patch')
-rw-r--r--gnu/packages/patches/ghostscript-freetype-compat.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/ghostscript-freetype-compat.patch b/gnu/packages/patches/ghostscript-freetype-compat.patch
new file mode 100644
index 0000000000..cc225b5ad6
--- /dev/null
+++ b/gnu/packages/patches/ghostscript-freetype-compat.patch
@@ -0,0 +1,35 @@
+Fix build with FreeType 2.10.3 and newer.
+
+Taken from upstream:
+https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=41ef9a0bc36b9db7115fbe9623f989bfb47bbade
+
+diff --git a/base/fapi_ft.c b/base/fapi_ft.c
+--- a/base/fapi_ft.c
++++ b/base/fapi_ft.c
+@@ -125,7 +125,7 @@ static void
+ delete_inc_int_info(gs_fapi_server * a_server,
+ FT_IncrementalRec * a_inc_int_info);
+
+-FT_CALLBACK_DEF(void *)
++static void *
+ FF_alloc(FT_Memory memory, long size)
+ {
+ gs_memory_t *mem = (gs_memory_t *) memory->user;
+@@ -133,7 +133,7 @@ FF_alloc(FT_Memory memory, long size)
+ return (gs_malloc(mem, size, 1, "FF_alloc"));
+ }
+
+-FT_CALLBACK_DEF(void *)
++static void *
+ FF_realloc(FT_Memory memory, long cur_size, long new_size, void *block)
+ {
+ gs_memory_t *mem = (gs_memory_t *) memory->user;
+@@ -153,7 +153,7 @@ FT_CALLBACK_DEF(void *)
+ return (tmp);
+ }
+
+-FT_CALLBACK_DEF(void)
++static void
+ FF_free(FT_Memory memory, void *block)
+ {
+ gs_memory_t *mem = (gs_memory_t *) memory->user;