summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch')
-rw-r--r--gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch b/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
deleted file mode 100644
index c1ef6a837c..0000000000
--- a/gnu/packages/patches/ghc-microlens-aeson-fix-tests.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-This patch fixes the test suite to allow any order when listing the
-members of a JSON object. Aeson (being true to the JSON specification)
-does not specify an order for objects. In practice, the order depends
-on your processor architecture.
-
-See <https://github.com/bos/aeson/issues/568> for a discussion resulting
-in a similar patch fixing the Aeson tests.
-
-See <https://github.com/fosskers/microlens-aeson/issues/1> for the
-upstream bug report.
-
-diff -ruN a/test/Test.hs b/test/Test.hs
---- a/test/Test.hs 2018-12-31 15:10:50.000000000 -0500
-+++ b/test/Test.hs 2019-11-08 01:34:07.419706831 -0500
-@@ -48,8 +48,10 @@
- , testCase "" $ ("{\"a\": {}, \"b\": null}" ^? key (T.pack "b") . _Object) @?= Nothing
- , testCase "" $ ("{\"a\": 100, \"b\": 200}" ^? key (T.pack "a")) @?= Just (Number 100.0)
- , testCase "" $ ("[1,2,3]" ^? key (T.pack "a")) @?= Nothing
-- , testCase "" $ ("{\"a\": 4, \"b\": 7}" ^.. members) @?= [Number 4.0,Number 7.0]
-- , testCase "" $ ("{\"a\": 4, \"b\": 7}" & members . _Number %~ (* 10)) @?= "{\"a\":40,\"b\":70}"
-+ , testCase "" $ assertBool "" (let x = ("{\"a\": 4, \"b\": 7}" ^.. members)
-+ in x == [Number 4.0,Number 7.0] || x == [Number 7.0,Number 4.0])
-+ , testCase "" $ assertBool "" (let x = ("{\"a\": 4, \"b\": 7}" & members . _Number %~ (* 10))
-+ in x == "{\"a\":40,\"b\":70}" || x == "{\"b\":70,\"a\":40}")
- , testCase "" $ ("[1,2,3]" ^? nth 1) @?= Just (Number 2.0)
- , testCase "" $ ("{\"a\": 100, \"b\": 200}" ^? nth 1) @?= Nothing
- , testCase "" $ ("[1,2,3]" & nth 1 .~ Number 20) @?= "[1,20,3]"