summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gcc-6-fix-buffer-size.patch
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-11-16 14:54:04 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-11-16 15:02:48 +0100
commitf2c6375449d085393eb538240200840ff242a743 (patch)
tree97694ea5dfca9c4a6ee6126783ff914c44bd0fce /gnu/packages/patches/gcc-6-fix-buffer-size.patch
parent455daf46adadf47582f57ff2ec8898b927913793 (diff)
downloadguix-patches-f2c6375449d085393eb538240200840ff242a743.tar
guix-patches-f2c6375449d085393eb538240200840ff242a743.tar.gz
gnu: gcc-vc4: Update to commit 0fe4b83897341742f9df65797474cb0feab4b377.
* gnu/packages/patches/gcc-6-fix-buffer-size.patch: New file. * gnu/packages/patches/gcc-6-fix-isl-includes.patch: New file. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/embedded.scm (gcc-vc4): Update to commit 0fe4b83897341742f9df65797474cb0feab4b377. [source]: Add the patches from above.
Diffstat (limited to 'gnu/packages/patches/gcc-6-fix-buffer-size.patch')
-rw-r--r--gnu/packages/patches/gcc-6-fix-buffer-size.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/gcc-6-fix-buffer-size.patch b/gnu/packages/patches/gcc-6-fix-buffer-size.patch
new file mode 100644
index 0000000000..5fcd769d45
--- /dev/null
+++ b/gnu/packages/patches/gcc-6-fix-buffer-size.patch
@@ -0,0 +1,15 @@
+Fixes a possible buffer overflow. (There are others)
+Author: Danny Milosavljevic <dannym@scratchpost.org>
+Date: 2020-11-16
+
+--- a/gcc/gimplify.c.orig 2020-10-29 08:45:11.532479774 +0100
++++ b/gcc/gimplify.c 2020-10-29 08:45:49.584637018 +0100
+@@ -5229,7 +5229,7 @@
+ flexibility, split it into separate input and output
+ operands. */
+ tree input;
+- char buf[10];
++ char buf[12];
+
+ /* Turn the in/out constraint into an output constraint. */
+ char *p = xstrdup (constraint);