summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gash-utils-ls-test.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-07-02 23:27:04 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-02 23:54:02 +0200
commitaf74c0633aa62d7d4e341920cfa3265f27f793cf (patch)
treeed682af020dfd7a002208909a6cd3b04fbecbb00 /gnu/packages/patches/gash-utils-ls-test.patch
parent2807a8432aa2aaac6fa7024974be6468ca1160b5 (diff)
downloadguix-patches-af74c0633aa62d7d4e341920cfa3265f27f793cf.tar
guix-patches-af74c0633aa62d7d4e341920cfa3265f27f793cf.tar.gz
gnu: gash, gash-utils: Build with Guile 3.0.
* gnu/packages/shells.scm (gash)[source]: Add 'modules' and 'snippet'. [inputs]: Change GUILE-2.2 to GUILE-3.0. (gash-utils)[source]: Add 'modules' and 'snippet'. [inputs]: Change GUILE-2.2 to GUILE-3.0. * gnu/packages/commencement.scm (gash-utils-boot)[source]: Remove unneeded 'modules' field, and add 'snippet'. (gash-utils-boot)[source]: New field. * gnu/packages/patches/gash-utils-ls-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/gash-utils-ls-test.patch')
-rw-r--r--gnu/packages/patches/gash-utils-ls-test.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/gash-utils-ls-test.patch b/gnu/packages/patches/gash-utils-ls-test.patch
new file mode 100644
index 0000000000..e1dfb9c23b
--- /dev/null
+++ b/gnu/packages/patches/gash-utils-ls-test.patch
@@ -0,0 +1,25 @@
+'ls.scm' monkey-patches (ice-9 getopt-long) to allow it to recognize '-1'
+as a valid option. Unfortunately, monkey patching no longer works with
+Guile 3.0 due to inlining, so change the test to make do without '-1'.
+
+diff --git a/tests/core-utils.org b/tests/core-utils.org
+index d35ede8..22718e3 100644
+--- a/tests/core-utils.org
++++ b/tests/core-utils.org
+@@ -93,14 +93,11 @@
+ * ls
+ :script:
+ #+begin_src sh
+- ls -1 tests/data/star
++ ls tests/data/star
+ #+end_src
+ :stdout:
+ #+begin_example
+- 0
+- 1
+- 2
+- 3
++ 0 1 2 3
+ #+end_example
+
+ * test-file