summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ganeti-shepherd-master-failover.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-03 00:28:57 +0200
committerMarius Bakke <marius@gnu.org>2020-07-16 21:51:43 +0200
commit72a91d74cec01bfcfcef2b62c5b327fab82950b6 (patch)
treed93d3d99a5b2fe2f06765286e72cc89e17195b98 /gnu/packages/patches/ganeti-shepherd-master-failover.patch
parent851cc11cd1c28178110ea7db5d528b342e9bc5be (diff)
downloadguix-patches-72a91d74cec01bfcfcef2b62c5b327fab82950b6.tar
guix-patches-72a91d74cec01bfcfcef2b62c5b327fab82950b6.tar.gz
gnu: Add ganeti.
* gnu/packages/virtualization.scm (system->qemu-target, ganeti): New variables. * gnu/packages/patches/ganeti-deterministic-manual.patch, gnu/packages/patches/ganeti-disable-version-symlinks.patch, gnu/packages/patches/ganeti-drbd-compat.patch, gnu/packages/patches/ganeti-haskell-pythondir.patch, gnu/packages/patches/ganeti-os-disk-size.patch, gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch, gnu/packages/patches/ganeti-shepherd-master-failover.patch, gnu/packages/patches/ganeti-shepherd-support.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/ganeti-shepherd-master-failover.patch')
-rw-r--r--gnu/packages/patches/ganeti-shepherd-master-failover.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/ganeti-shepherd-master-failover.patch b/gnu/packages/patches/ganeti-shepherd-master-failover.patch
new file mode 100644
index 0000000000..36a7918998
--- /dev/null
+++ b/gnu/packages/patches/ganeti-shepherd-master-failover.patch
@@ -0,0 +1,18 @@
+By default, master-failover will call "herd start ganeti-wconfd" with
+extra arguments such as --force-node. That does not work with the
+Shepherd, so the Guix service has a "force-start" action for this purpose.
+
+diff --git a/lib/bootstrap.py b/lib/bootstrap.py
+--- a/lib/bootstrap.py
++++ b/lib/bootstrap.py
+@@ -1011,9 +1011,7 @@ def MasterFailover(no_voting=False):
+
+ try:
+ # Forcefully start WConfd so that we can access the configuration
+- result = utils.RunCmd([pathutils.DAEMON_UTIL,
+- "start", constants.WCONFD, "--force-node",
+- "--no-voting", "--yes-do-it"])
++ result = utils.RunCmd(["herd", "force-start", constants.WCONFD])
+ if result.failed:
+ raise errors.OpPrereqError("Could not start the configuration daemon,"
+ " command %s had exitcode %s and error %s" %