summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 23:41:51 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:54:03 -0500
commit98f147dbda124ab3a9412542de106d8f7f31a6a5 (patch)
treec58de36e1a600ab7793b2a5e4542499d49048730 /gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch
parenta0658f1a335f7b2eb8475cd4481ef35e22dc911c (diff)
downloadguix-patches-98f147dbda124ab3a9412542de106d8f7f31a6a5.tar
guix-patches-98f147dbda124ab3a9412542de106d8f7f31a6a5.tar.gz
gnu: ganeti: Remove PYTHONPATH-altering patch.
* gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Un-register it. * gnu/packages/virtualization.scm (ganeti): Remove patch.
Diffstat (limited to 'gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch')
-rw-r--r--gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch b/gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch
deleted file mode 100644
index 1358e30633..0000000000
--- a/gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Do not override PYTHONPATH when calling Python code from the Haskell
-daemons. This is necessary because the Python library dependencies are
-only available through PYTHONPATH.
-
-diff --git a/src/Ganeti/Query/Exec.hs b/src/Ganeti/Query/Exec.hs
---- a/src/Ganeti/Query/Exec.hs
-+++ b/src/Ganeti/Query/Exec.hs
-@@ -99,12 +99,10 @@ spawnJobProcess jid = withErrorLogAt CRITICAL (show jid) $
- do
- use_debug <- isDebugMode
- env_ <- (M.toList . M.insert "GNT_DEBUG" (if use_debug then "1" else "0")
-- . M.insert "PYTHONPATH" AC.pythondir
- . M.fromList)
- `liftM` getEnvironment
- execPy <- P.jqueueExecutorPy
- logDebug $ "Executing " ++ AC.pythonPath ++ " " ++ execPy
-- ++ " with PYTHONPATH=" ++ AC.pythondir
-
- (master, child) <- pipeClient connectConfig
- let (rh, wh) = clientToHandle child
-