summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/freecad-boost-serialization.patch
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-11-29 15:40:11 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-11-30 21:27:13 +0100
commit6805ab3290f54cd1859f54e23d0213b110b07764 (patch)
treefbd9450d1646dd5ab5dc9bb95b7efea6b00d5982 /gnu/packages/patches/freecad-boost-serialization.patch
parent2d0c5e2477edc34819a8ee1c48aad306e0801bc1 (diff)
downloadguix-patches-6805ab3290f54cd1859f54e23d0213b110b07764.tar
guix-patches-6805ab3290f54cd1859f54e23d0213b110b07764.tar.gz
gnu: freecad: Fix build.
* gnu/packages/patches/freecad-boost-serialization.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/engineering.scm (freecad) [source]: Use it. [arguments]{#:configure-flags}: Turn it into a GEXP and adapt it.
Diffstat (limited to 'gnu/packages/patches/freecad-boost-serialization.patch')
-rw-r--r--gnu/packages/patches/freecad-boost-serialization.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/freecad-boost-serialization.patch b/gnu/packages/patches/freecad-boost-serialization.patch
new file mode 100644
index 0000000000..374eabc966
--- /dev/null
+++ b/gnu/packages/patches/freecad-boost-serialization.patch
@@ -0,0 +1,27 @@
+Taken from: https://github.com/archlinux/svntogit-community/blob/packages/freecad/trunk/freecad-boost.patch.
+
+Index: FreeCAD-0.19.2/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -46,6 +46,7 @@ if(NOT FREECAD_LIBPACK_USE OR FREECAD_LI
+ SetupPCL()
+ SetupPybind11()
+ SetupBoost()
++ set(Boost_LIBRARIES_App ${Boost_LIBRARIES})
+ SetupXercesC()
+ find_package(ZLIB REQUIRED)
+ find_package(PyCXX REQUIRED)
+Index: FreeCAD-0.19.2/src/App/CMakeLists.txt
+===================================================================
+--- a/src/App/CMakeLists.txt
++++ b/src/App/CMakeLists.txt
+@@ -59,7 +59,7 @@ include_directories(
+
+ set(FreeCADApp_LIBS
+ FreeCADBase
+- ${Boost_LIBRARIES}
++ ${Boost_LIBRARIES_App}
+ )
+
+ if (BUILD_QT5)