summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-04-23 02:35:03 -0400
committerMark H Weaver <mhw@netris.org>2020-08-28 00:13:51 -0400
commit36a09d185343375a5cba370431870f9c4435d623 (patch)
treebdb3751308a3a7d83ef098acc677e28974c7d10d /gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
parentc05d2cfcbedaae5424149b8060a61bacdf81a119 (diff)
downloadguix-patches-36a09d185343375a5cba370431870f9c4435d623.tar
guix-patches-36a09d185343375a5cba370431870f9c4435d623.tar.gz
gnu: emacs: Update to 27.1.
* gnu/packages/emacs.scm (emacs): Update to 27.1. [source]: In snippet, use 'find-files' to find 'eshell/esh-groups.el' if it exists, but gracefully handle its absence. [arguments]: Add "--with-cairo" to configure-flags. Add 'restore-emacs-pdmp' and 'make-compressed-files-writable' phases. Explicitly return #t from 'install-site-start' phase. [inputs]: Add cairo, pango, harfbuzz, jansson, and gmp. Remove imagemagick. (emacs-next): Remove variable. (emacs-minimal, emacs-xwidgets): Use 'package/inherit'. [arguments]: Remove 'restore-emacs-pdmp' phase. (emacs-no-x): Use 'package/inherit'. [arguments]: Remove "--with-cairo" from configure-flags. Remove 'restore-emacs-pdmp' phase. [inputs]: Remove cairo, pango, and harfbuzz. (emacs-no-x-toolkit): Use 'package/inherit'. [arguments]: Remove 'restore-emacs-pdmp' phase. Remove superfluous quasiquote+unquote-splicing pair. (emacs-wide-int): Use 'package/inherit'. (guile-emacs): Use 'package/inherit'. [arguments]: Remove "--with-cairo" from configure-flags. Remove 'restore-emacs-pdmp' phase. * gnu/packages/patches/emacs-ignore-empty-xim-styles.patch, gnu/packages/patches/emacs-source-date-epoch.patch: Adapt to apply cleanly to emacs-27.1. * gnu/packages/patches/emacs-exec-path.patch: Replace with the previous contents of 'emacs27-exec-path.patch', but remove the superfluous comment about it being "like emacs-exec-path.patch, but for Emacs 27". * gnu/packages/patches/emacs27-exec-path.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove 'emacs27-exec-path.patch'.
Diffstat (limited to 'gnu/packages/patches/emacs-ignore-empty-xim-styles.patch')
-rw-r--r--gnu/packages/patches/emacs-ignore-empty-xim-styles.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch b/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
index 606d3ece6f..398e65bdc8 100644
--- a/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
+++ b/gnu/packages/patches/emacs-ignore-empty-xim-styles.patch
@@ -5,7 +5,7 @@ Index: emacs-26.3/src/xfns.c
===================================================================
--- emacs-26.3.orig/src/xfns.c
+++ emacs-26.3/src/xfns.c
-@@ -2533,6 +2533,8 @@ xic_free_xfontset (struct frame *f)
+@@ -2628,6 +2628,8 @@ xic_free_xfontset (struct frame *f)
static XIMStyle
best_xim_style (XIMStyles *xim)
{
@@ -14,7 +14,7 @@ Index: emacs-26.3/src/xfns.c
int i, j;
int nr_supported = ARRAYELTS (supported_xim_styles);
-@@ -2541,6 +2543,7 @@ best_xim_style (XIMStyles *xim)
+@@ -2636,6 +2638,7 @@ best_xim_style (XIMStyles *xim)
if (supported_xim_styles[i] == xim->supported_styles[j])
return supported_xim_styles[i];