summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/combinatorial-blas-io-fix.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@cray.com>2018-10-23 16:50:50 -0500
committerEric Bavier <bavier@member.fsf.org>2019-01-25 13:09:47 -0600
commita6b9ebc2fc92a72ca8a1e61e2d321804eec9d738 (patch)
treedfdec51557ac0a4577d3f3e713856688b92873c4 /gnu/packages/patches/combinatorial-blas-io-fix.patch
parent519be98c3536b5113cde368f9dc6db2e1ebe073e (diff)
downloadguix-patches-a6b9ebc2fc92a72ca8a1e61e2d321804eec9d738.tar
guix-patches-a6b9ebc2fc92a72ca8a1e61e2d321804eec9d738.tar.gz
gnu: Add Combinatorial BLAS.
* gnu/packages/maths.scm (combinatorial-blas): New variable. * gnu/packages/patches/combinatorial-blas-awpm.patch, gnu/packages/patches/combinatorial-blas-io-fix.patch: New files * gnu/local.mk(dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/combinatorial-blas-io-fix.patch')
-rw-r--r--gnu/packages/patches/combinatorial-blas-io-fix.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/combinatorial-blas-io-fix.patch b/gnu/packages/patches/combinatorial-blas-io-fix.patch
new file mode 100644
index 0000000000..0ad28e5e0b
--- /dev/null
+++ b/gnu/packages/patches/combinatorial-blas-io-fix.patch
@@ -0,0 +1,14 @@
+IO not appropriate in the context of a sorting routine, and in any case the
+proper headers are not included, so gcc emits an undefined symbol error.
+Remove the "printf" statement.
+
+--- CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
++++ CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
+@@ -142,7 +142,6 @@
+ }
+ if ( (a[nmax]==a[nmin]) && (ctr==0) )
+ {
+- printf("All the numbers are identical, the list is sorted\n");
+ return;
+ }
+