summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/clementine-fix-sqlite.patch
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-02-02 08:16:22 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-08 11:14:42 +0100
commit7b207e08492998bb91ac99f703f193d32dfee31e (patch)
tree6380e2160d1c6a39686d480d3ef647a4c6ec4903 /gnu/packages/patches/clementine-fix-sqlite.patch
parenta31b72655d1127dfd67508ab2625fe518b83d009 (diff)
downloadguix-patches-7b207e08492998bb91ac99f703f193d32dfee31e.tar
guix-patches-7b207e08492998bb91ac99f703f193d32dfee31e.tar.gz
gnu: clementine: Update to 1.4.0rc1-450.
* gnu/packages/music.scm (clementine): Update to 1.4.0rc1-450. [source]: Adapt snippet to list bundled directories to keep rather than ones to delete. Unbundled gmock. Remove patches no longer needed. [arguments]: Set -DUSE_SYSTEM_TAGLIB=TRUE. [native-inputs]: Add googletest. [inputs]: Remove openssl. [license]: Remove gmock license. * gnu/packages/patches/clementine-fix-sqlite.patch: Remove. * gnu/packages/patches/clementine-remove-crypto++-dependency.patch: Remvoe * gnu/packages/patches/clementine-use-openssl.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove them. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/patches/clementine-fix-sqlite.patch')
-rw-r--r--gnu/packages/patches/clementine-fix-sqlite.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/patches/clementine-fix-sqlite.patch b/gnu/packages/patches/clementine-fix-sqlite.patch
deleted file mode 100644
index f9d44f9074..0000000000
--- a/gnu/packages/patches/clementine-fix-sqlite.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Patch downloaded from https://github.com/clementine-player/Clementine/pull/5669 .
-
-diff -ruN clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp clementine-1.3.1.565.gd20c2244a/src/core/database.cpp
---- clementine-1.3.1.565.gd20c2244a.orig/src/core/database.cpp 2018-07-07 23:59:24.018540126 +0200
-+++ clementine-1.3.1.565.gd20c2244a/src/core/database.cpp 2018-07-08 00:04:47.991551728 +0200
-@@ -265,6 +265,17 @@
- StaticInit();
-
- {
-+
-+#ifdef SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER
-+ // In case sqlite>=3.12 is compiled without -DSQLITE_ENABLE_FTS3_TOKENIZER
-+ // (generally a good idea due to security reasons) the fts3 support should be enabled explicitly.
-+ QVariant v = db.driver()->handle();
-+ if (v.isValid() && qstrcmp(v.typeName(), "sqlite3*") == 0) {
-+ sqlite3 *handle = *static_cast<sqlite3**>(v.data());
-+ if (handle) sqlite3_db_config(handle, SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER, 1, NULL);
-+ }
-+#endif
-+
- QSqlQuery set_fts_tokenizer(db);
- set_fts_tokenizer.prepare("SELECT fts3_tokenizer(:name, :pointer)");
- set_fts_tokenizer.bindValue(":name", "unicode");